[DOGFOOD] [PP] Crash dismissing compose window after posting to news server

VERIFIED WORKSFORME

Status

MailNews Core
Composition
P3
normal
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: pmock, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
PowerPC
Mac System 8.5

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
Build Date & Platform Bug Found:
  Mac mozilla seamonkey build 1999-09-29-08-m11 installed on G3/400 MacOS 8.5.1

Overview Description:

After posting to a netscape.test newsgroup on news.mozilla.org, I receive a
dialog that I am forced to click ok.  The dialog reads "[String ID 2147024809?]"
which I close.  The compose windows re-appears.  When I close the html compose
window, it crashes.  The news article that I sent does get posted to the
newsgroup.  On Win32 and Linux, I do not have to manual close the HTML compose
window.

Steps to Reproduce:
0) Delete my previous mozilla registry file and 5.0 user profile
1) Migrate 1 profile that contained a newsgroup, netscape.test
   I migrated a pop profile.  You may crash b/c of bug 14600.
2) Launch apprunner
3) Open Messenger from the browser
4) Expand the list of newsgroup
   I was using news.mozilla.org
5) Select a newsgroup, netscape.test
   The list of news articles should appear
6) Click on the new msg icon off the toolbar
7) Address the message to netscape.test and change the recipient type to
'newsgroup'
8) Type in a subject and a short message
9) Click on the send button
   The compose windows disappears but a dialog appears which reads,
   "[String ID 2147024809?]".  There is a ok button.
10) Click on the OK button
    The dialog disappears and my compose window returns.
11) Click on the close button on the title bar of the window.
    Application crashes.

Actual Results:

 The applications crashes.  If I try to escape out of Macsbug, talkback does not
launch.

Expected Results:
 The application should not crash.  It should send and close the compose window.

Additional Builds and Platforms Tested On:
 On win32 1999-09-29-08
and linux 1999-09-29-09 builds, I do not have this problem.  It does not crash
and it closes the compose window after sending.

Additional Information:
 On Mac, when I send via pop mail, this problem does not occur.

Comment 1

19 years ago
IMAP has this problem:  http://bugzilla.mozilla.org/show_bug.cgi?id=14591
(Reporter)

Comment 2

19 years ago
Update: on M10 Mac commercial seamonkey build 1999-10-01-20-m10, I do not crash
when I post a new article, but I still have to manually close the compose
window.
(Reporter)

Comment 3

19 years ago
Update.  I still crash using the M11 mac commercial seamonkey build
1999-10-05-12-m11.  The first message I send does not crash but if I keep
posting and sending message I crash.
(Reporter)

Comment 4

19 years ago
On M10, there still may be crash.

Updated

19 years ago
Summary: [PP] Crash dismissing compose window after posting to news server → [DOGFOOD] [PP] Crash dismissing compose window after posting to news server

Comment 5

19 years ago
I'd like to recommend this bug for DOGFOOD usage that the PDT reviews.

Updated

19 years ago
Whiteboard: [PDT+]

Comment 6

19 years ago
Putting on [PDT+] radar.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M11
(Assignee)

Comment 7

19 years ago
Peter, when you post the message, how many recipients did you defined?
(Reporter)

Comment 8

19 years ago
Just one recepient.
(Assignee)

Comment 9

19 years ago
I cannot reproduce the crash. I cannot post the message either, get the string ID error.
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 10

19 years ago
Now I am able to poste successfully a message without any crash.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

19 years ago
I can not reproduce this problem either.  The compose window dismisses by itself
after sending mail message.

Verified as worksforme using the following build:
ftp://sweetlou/products/client/seamonkey/macos/8.x/ppc/1999-10-20-11-M11/netscape5-mac-M11.sea.bin
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.