Closed Bug 1521314 Opened 7 years ago Closed 7 years ago

Forgotten password not asked, timeout on server

Categories

(Thunderbird :: Untriaged, defect)

52 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1521531

People

(Reporter: bty-adminf1, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3676.0 Safari/537.36

Steps to reproduce:

Let TH do is job after load

Actual results:

One account is no more downloaded (pop3)
I search for the password into the list, there is no more for this account
Later TH asks for the passw. I give it but after verification the mailbox id is truncated the "@..." is missing.
I delete it.
Currently the password is not asked, the connection to server begin but seems to stop on the missing password and leads to a server timeout (notified).
The is no known solution.
The mailbox cannot be anymore accessed.

Nota :

Expected results:

If the password is not defined (missing, not only wrong or refused by the server) for an account in any case it must be asked to the user.
If asked, the pass must be well stored (currently it is not : error on the @... truncated, but when and conditions ?

Anyway a reset procedure to clean the account pass and reset all from the account definition is needed but currently absent (suppressed from a very old version long years ago : "modification of passwords").

This is needed for reliability because if something happens into the process which generates the pass request the user is led to a dead lock.

Note :
My job is stopped since two days.
Because of the great number of mail I cannot use another computer or smartphone which do not manages the condition for a pop : download since a defined date.
The server (OVH) webmail is roundcube, which is unable to load the mailbox (2.6 Go) but tells that 270 message marked as new (never downloaded) are waiting.

Note2 : my mail account here is linked to this box...

Is it confirmed that bitdefender isn't causing an issue here?

Anyway a reset procedure to clean the account pass and reset all from the account definition is needed but currently absent (suppressed from a very old version long years ago : "modification of passwords").

please list exact steps, click by click, of what isn't working

Flags: needinfo?(bty-adminf1)

Hi,

Before my answer to your question, please note this :

  • the version is 60.4
  • I have currently two problem to communicate on the site :
    • The account locked is my current account here, so I don't receive the mails of all my site, forum and account on net since one week.
    • I had a crash (BSOD on synTP : 40 times with no solution found) and thought that this report had been lost before saving. More my parameters for searching where wrong, I just reset the default in advanced search.

consequently 1521531 repeats, but with complements and probably more clear, this 1521314(because of more advanced analysis).

I think that we can keep this in mind but transfer to my new report.

For what happens the best is the download of video from cloud (I must not transmit the url in public space). I have before upload to cut unuseful sequences to get a short video.

what isn't working

I think that my explanation in 1521531 is better because more recent, but the following may be more detailed too.

I summarise (I will copy this into 1521531) :

  • Existing accounts with homonimy : support@m1, support@m2 (with same password)
  • for unknown reason (may be a temporarily server problem) an error or timeout occurs and the password is asked, generally I retry or cancel and it had not re-appeared for a while.
  • One day I gave it and it has been refused while it was exact.
  • I discover then that a password stored is for an not existing account "support"
  • I have deleted it (hope to get again the question and anomaly to disappear)
  • When TB tries to connect it says (bottom of window) : connecting to : "server (not displayed)" ssl0.ovh.net (without the account concerned) we reach a timeout but for which account ? : unknown, all uses ssl0.ovh.net.
  • sometimes it asks, before the timeout, for a password for "support" without the full account name (old enhancement request which had been normally treated) but when I give it I get an error. The full account name is into the second message that the full account name is displayed and I can see that it is a very old account given for which the pass is naturally false. For a partial solution I will find back this account name and change the pass from my manager (I am the manager of these mails accounts), then get a good one and hope to go to an issue to reset the accounts, this because I can hope that this account and password will be stored well but I am not sure because of the previous error.

Explanation (a theory):

  • Something (I am going to the different reports) creates maybe an error in passwords : it is not normal to find a password stored for "support" without the "@m1" in my example. We can imagine that TB believes to send a password while it sends nothing... timeout ?
  • Currently TH never asks for the password of the right account.
  • This is complicated by the fact that the automatic read of account (each five minutes) creates a stack which cannot be emptied most of time because of the timeout.
  • The fact that, once a good pass but with a bad account (reduced to the first part "support") has been stored let think that this error will reappear.

Currently the pass is never recorded (doesn't appear into the list of pass) because there is never a valid pass given because the account associated to the question of the pass is unknown...

Flags: needinfo?(bty-adminf1)
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.