The yellow star used to mark messages is truncated in the right side, missing 1 or 2 pixels

RESOLVED FIXED in Thunderbird 66.0

Status

defect
--
trivial
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: cristian, Assigned: Paenglab)

Tracking

Thunderbird 66.0

Thunderbird Tracking Flags

(thunderbird_esr6065+ fixed, thunderbird65 fixed, thunderbird66 fixed)

Details

Attachments

(4 attachments)

(Reporter)

Description

3 months ago
Posted image Thunderbird_star.jpg

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

Hello from Romania. I would like to report following bug. The yellow star used to mark the messages, is truncated in the right side, missing 1 or 2 pixels.

Look very close. Have to enlarge the column a little bit (1 or 2 pixel) to have space enough for the yellow star. Maybe nobody seen yet but looks bad for a professional look and I see it as I use a lot that star to mark messages. Is like unfinished software.

Actual results:

This problem seems was also 10 years in the Bug 439628.

That time was different, the column border cutted the star.

This time, the star is truncated even when the right border is moved on the right side. See picture attached.

Should be a problem about "padding" of the border line (the space from the border line), that space cut the star arm 1 or 2 pixels. Maybe simple fix, move the border line even more 1pixel to the right side, will fix. If is not from the column, then should be from padding on the right side.

Expected results:

The same problem was also in the ver. 50 and now is on the 60 as well. Today I had time to write you about. Please fix it for me.

I use Thunderbird since before 2004, I even don't remember exactly already when I start using it.

Updated

3 months ago
Summary: Hello from Romania. I would like to report following bug. The yellow star used to mark the messages, is truncated in the right side, missing 1 or 2 pixels. → The yellow star used to mark messages is truncated in the right side, missing 1 or 2 pixels

Comment 1

3 months ago

What is creating the yellow Menu Bar?

Does the same problem occur in safe mode? Use Help > Restart with Add-ons Disabled.

Comment 2

3 months ago

The yellow is most likely the Windows accent colour.

Reporter, I can't see anything cut off. Rirchard, can you?

Flags: needinfo?(richard.marti)
(Assignee)

Comment 3

3 months ago
Posted image star.png

This shows it better. The tip on the right is a bit dull.

Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(richard.marti)
(Assignee)

Comment 4

3 months ago

This fixes it.

Attachment #9037867 - Flags: review?(jorgk)
Attachment #9037867 - Flags: approval-comm-esr60?

Comment 5

3 months ago
Comment on attachment 9037867 [details] [diff] [review]
1521376-move-star.patch

Review of attachment 9037867 [details] [diff] [review]:
-----------------------------------------------------------------

OK, thanks.
Attachment #9037867 - Flags: review?(jorgk)
Attachment #9037867 - Flags: review+
Attachment #9037867 - Flags: approval-comm-esr60?
Attachment #9037867 - Flags: approval-comm-esr60+
Attachment #9037867 - Flags: approval-comm-beta+
(Assignee)

Updated

3 months ago
Keywords: checkin-needed

Comment 6

3 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/ff32d5c4c737
Move the star icon to the left with a negative margin instead a padding. r=jorgk

Status: ASSIGNED → RESOLVED
Last Resolved: 3 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

3 months ago
Target Milestone: --- → Thunderbird 66.0
(Reporter)

Comment 8

3 months ago

Hello.
Seems that my post was useful, I'm glad :)
Please send me a printr-screen about how looking fixed.

Thanks,
Cristian

Comment 9

3 months ago
Posted image star.png

Here you go. Yes, we fixed it and a better star will ship in TB 60.5 at the end of the month.

Updated

3 months ago
Severity: normal → trivial
Component: Untriaged → Theme
You need to log in before you can comment on or make changes to this bug.