Closed Bug 1521423 Opened 1 year ago Closed 1 year ago

Links to comments are not correct in bugmail

Categories

(bugzilla.mozilla.org :: Email Notifications, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: emk, Assigned: kohei)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review

Steps to reproduce:
Click this link in the bugmail: -> comment #0.

Actual result:
The Bugizlla Main Page will open.

Expected result:
This comment should open.

Blocks: bmo-markdown
Keywords: regression
Version: Staging → Production
Duplicate of this bug: 1523107
Assignee: nobody → dylan
Duplicate of this bug: 1525317
Duplicate of this bug: 1528454

Any ETA on fixing this regression?

Duplicate of this bug: 1534704
No longer blocks: bmo-markdown
Regressed by: bmo-markdown
Blocks: bmo-markdown
Regressed by: bmo-markdown-initial-release
No longer regressed by: bmo-markdown
Status: NEW → ASSIGNED

This bug and bug 832993 are both about relative URLs. In that other bug, the issue was caused by the lack of <base> support.

In this case, <base> is supported, but since the links only consist of a reference fragment (#c0), and the <base> element is <base href="https://bugzilla.mozilla.org/">, the link points to the homepage, not the specific bug on which the comment was made.

See Also: → 832993

Kohei, is that something you can help with?
Thanks

Flags: needinfo?(kohei.yoshino)

Will have a look today.

Assignee: dylan → kohei.yoshino
Flags: needinfo?(kohei.yoshino)
Attached file GitHub Pull Request

My PR won’t fix Bug 832993 which is a different issue from this regression.

The wrong links here are missing the path:

<a href="#c4">Comment 4</a>

With my fix, it will look like:

<a href="/show_bug.cgi?id=1521423#c4" title="NEW - Links to comments are not correct in bugmail">Comment 4</a>

It’s still a relative URL like other bug links.

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.