Closed Bug 1521481 Opened 9 months ago Closed 9 months ago

chat conversations number indicator showing funny bubbles with zero

Categories

(Thunderbird :: Instant Messaging, defect)

defect
Not set

Tracking

(thunderbird65 fixed, thunderbird66 fixed)

RESOLVED FIXED
Thunderbird 66.0
Tracking Status
thunderbird65 --- fixed
thunderbird66 --- fixed

People

(Reporter: mkmelin, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(1 file)

+++ This bug was initially created as a clone of Bug #1519091 +++
Bug 1519091 made the main chat conversation browser work again, but after that, the conversations show a funny bubble with zero next to conversations with no new.

It's unclear if this is from that bug, or something that regressed during the time chat was broken. (Possibly something related to richlist/richlistitem.)

Starting point for debuggning: convUnreadTargetedCount: https://searchfox.org/comm-central/source/mail/components/im/content/imconv.xml#33

Jörg had a screenshot https://imgur.com/a/BR2E39w

(In reply to Magnus Melin [:mkmelin] from comment #0)

It's unclear if this is from that bug, or something that regressed during the time chat was broken. (Possibly something related to richlist/richlistitem.)

I think it's the latter, as I can't reproduce on my local build on which I applied the patches from bug 1519091 to review them. I haven't pulled m-c/c-c since the review of the first version of that patch (I'm currently on revision 66b68c6b6221 on m-c, that's from Wednesday January 16).

Or it could be because of bug 1444987 which added a box around the convUnreadTargetedCountLabel to make the border-radius apply.

I suspect this is a regression from bug 1444987.

This fixes it for me. Is there a more elegant way?

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9037992 - Flags: review?(florian)
Comment on attachment 9037992 [details] [diff] [review]
1521481-hide.unread-count.patch

Review of attachment 9037992 [details] [diff] [review]:
-----------------------------------------------------------------

wfm, thanks!
Attachment #9037992 - Flags: review?(florian) → review+
Keywords: checkin-needed
Comment on attachment 9037992 [details] [diff] [review]
1521481-hide.unread-count.patch

Regression from bug 1444987.
Attachment #9037992 - Flags: approval-comm-beta?

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/51560879ea98
Hide chat conversation number indicator when its value is "0" by copying the xbl:inherits to the surrounding box. r=florian

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 66.0
Attachment #9037992 - Flags: approval-comm-beta? → approval-comm-beta+
Blocks: 1444987
You need to log in before you can comment on or make changes to this bug.