If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Entering combination of normal and bold text causes problems.

VERIFIED WORKSFORME

Status

MailNews Core
Composition
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: David Saxby, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
To reproduce:
1)  Open a new mail message compose window and move immediately to the message body.
2)  Type the following text into the message body,without pressing enter:
"Assuming you are using the PLSQL execution engine, the way to obtain the
desired effect is to call the "
3)  Select bold text, either from menu or ctrl-b
4)  Continue typing the following "ff_exec.run_formula"
5)  De-select bold text.
6)  Continue typing the following " procedure with the "
7)  Select bold text.
8)  Continue typing "p_use_dbi_cache". Notice that as soon as the "p" key is
pressed, the text cursor moves backwards and as you continue to type, the
"p_use_dbi_cache" appears immediately after the "ff_exec.run_formula" text (in
bold).
Expected result : the "p_use_dbi_cache" text should appear following the
"procedure with the " text.
Further notes:
1) When I beging to type, the settings shown in my mailnews window are "Body
Text" and "Variable Width", the normal settings.
2) I tried a few different things to see if I could track down exactly what the
problem is, by typing in various combinations of bold and normal text, but was
unable to pinpoint. Therefore, I've used the exact phrase that I was typing in a
mail that alerted me to the problem.
3) Have seen this on Mozilla 1.0 and Netscape 7.0 PR1 (which I believe means
it's been around since at least Moz rc2.
4) The "about:" screen displayed as: "Mozilla/5.0 (X11; U; Linux i686; en-US;
rv:1.0.0) Gecko/20020607"
5) Have not tried this on platforms other than Linux.

Comment 1

14 years ago
David Saxby, do you still see this bug with current versions of Mozilla?  I am 
unable to duplicate it, but I am using Windows.

If things are working OK for you now, please mark this bug
  Resolved|WorksForMe
(Reporter)

Comment 2

14 years ago
Agreed, this seems to have gone away and thus I am marking as resolved, as
requested.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME

Comment 3

14 years ago
v wfm
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.