Disable raising Timeout errors in window manipulation commands and increase timeout

RESOLVED FIXED in Firefox 65

Status

defect
P1
normal
RESOLVED FIXED
6 months ago
6 months ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

(Blocks 2 bugs, {regression})

Trunk
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox64 unaffected, firefox65 fixed, firefox66 fixed)

Details

Attachments

(1 attachment)

As discussed in the WebDriver meeting today we want to disable raising the timeout errors for window manipulation commands. This is to behave like we are trying our best to get into this mode, but cannot actually guarantee it.

The timeout in use right now is 1.5s only, which is actually too low. Alone on MacOS going in and out of fullscreen takes about 1s. Then we currently add the debounce callback timeout of 150ms on-top. I would propose to set a timeout of 5s for all the commands, which should result in a proper handling.

This is a regression from bug 1492499, and should be fixed and uplifted to mozilla-beta so it can reach the 65 release. Ryan, I hope that this is still possible, right?

Flags: needinfo?(ryanvm)

Marionette should do its best to get the browser into the requested
window state, but if it is not possible to do so, it shouldn't raise
a timeout error. This is mostly the case when running tests under
xvfb with no window manager running.

Further the timeout value has to be set to a value which wouldn't
cause the commands to inappropriately fail due to animations, or
a slow machine.

Attachment #9038019 - Attachment description: Bug 1521527 - [marionette] Only log timeout errors for all window manipulation commands. r?ato → Bug 1521527 - [marionette] Don't raise timeout errors for all window manipulation commands. r?ato
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4aafc1f415ad
[marionette] Don't raise timeout errors for all window manipulation commands. r=ato
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66

This test-only patch fixes a regression for Marionette in Firefox 65, which we really would like to see uplifted to beta if it is still possible. Thanks!

Whiteboard: [checkin-needed-beta]

As discussed on IRC we already automatically uplift to beta which is 66, so an uplift to 65 would be necessary in case another rc will be built.

Whiteboard: [checkin-needed-beta] → [checkin-needed-beta][checkin-needed-release]
Flags: needinfo?(ryanvm)
Whiteboard: [checkin-needed-beta][checkin-needed-release]
You need to log in before you can comment on or make changes to this bug.