member ‘mozilla::gfx::Point mozilla::gfx::PathOp::<unnamed union>::<unnamed struct>::mP2’ with constructor not allowed in anonymous aggregate

RESOLVED DUPLICATE of bug 1521391

Status

()

defect
P1
normal
RESOLVED DUPLICATE of bug 1521391
5 months ago
5 months ago

People

(Reporter: aceman, Unassigned)

Tracking

Trunk
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox66 affected)

Details

Reporter

Description

5 months ago

Since the version of mozilla-central of 2019-01-19 I get a new compile error with gcc 8.2:

mozilla/obj-x86_64-pc-linux-gnu/dist/include/mozilla/gfx/PathHelpers.h:36:13: error: member ‘mozilla::gfx::Point mozilla::gfx::PathOp::<unnamed union>::<unnamed struct>::mP2’ with constructor not allowed in anonymous aggregate
Point mP2;
^~~
mozilla/obj-x86_64-pc-linux-gnu/dist/include/mozilla/gfx/PathHelpers.h:37:13: error: member ‘mozilla::gfx::Point mozilla::gfx::PathOp::<unnamed union>::<unnamed struct>::mP3’ with constructor not allowed in anonymous aggregate
Point mP3;
^~~

Before that date I compiled m-c with gcc for months.
Is this a gcc bug or a new problem in the code?

The error appears for multiple files that include mozilla/obj-x86_64-pc-linux-gnu/dist/include/nsCSSRenderingBorders.h .

Component: CSS Parsing and Computation → Graphics

Marking P1 because of compile error.

Bas, I think this is caused by the changes from bug 1519739. Could you please take a look?

Blocks: 1519739
Flags: needinfo?(bas)
Priority: -- → P1

Actually this is a duplicate of bug 1521391.

No longer blocks: 1519739
Status: NEW → RESOLVED
Closed: 5 months ago
Flags: needinfo?(bas)
Resolution: --- → DUPLICATE
Duplicate of bug: 1521391
You need to log in before you can comment on or make changes to this bug.