On about:support, info is missing for Media, JavaScript, Accessibility, Library Versions, Sandbox and Internationalization & Localization parts

VERIFIED FIXED in Firefox 66

Status

()

defect
VERIFIED FIXED
5 months ago
4 months ago

People

(Reporter: guijoselito, Assigned: jaws)

Tracking

({steps-wanted})

Trunk
mozilla67
x86_64
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox65 wontfix, firefox66 verified, firefox67 verified)

Details

Attachments

(1 attachment)

Reporter

Description

5 months ago

about:support is not complete in today's Nightly.

Info from Media, JavaScript, Accessibility, Library Versions, Sandbox and Internationalization & Localization parts are not there.

In Browser Console there is:
TypeError: Argument 1 of Node.appendChild is not an object.[Learn More] aboutSupport.js:880:25

I'm using WebRender right now, and there are 10 slow frame notifications and 2 failure log, fwiw.

https://bugzilla.mozilla.org/show_bug.cgi?id=1521557 has the same error notification, and I'm pretty sure about:support was working 1 or 2 days ago, at least.

works for me with a current nightly on windows 10

Updated

5 months ago
Summary: Broken about:support → On about:support, info is missing for Media, JavaScript, Accessibility, Library Versions, Sandbox and Internationalization & Localization parts
Reporter

Comment 2

5 months ago

I think the problem only happens when there's a failure log. Right now it's not working and there is 1 error:
(#0) GP+[GFX1-]: shader-cache: Timed out before finishing loads

Jared, any idea about this? It looks like you worked recently on this code

Flags: needinfo?(jaws)
Keywords: steps-wanted
Product: Firefox → Toolkit
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Flags: needinfo?(jaws)

The failures were remaining in the data object, which later had any remaining keys printed in the diagnostics section. This bug was introduced because we stopped using Array objects to generate formatted strings. In the previous code, this would have ended up just printing out the first failure listed in the diagnostics section (a partial duplicate of the actual Failure Log).

Comment 5

5 months ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/36d845cdb7f0
Delete the failures data after it has been output. r=Gijs

Comment 6

5 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

Is this something we should consider backporting to Beta?

Flags: needinfo?(jaws)
Blocks: 1507595
Flags: needinfo?(jaws)

Comment on attachment 9040585 [details]
Bug 1521599 - Delete the failures data after it has been output. r?Gijs

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1507595

User impact if declined

Users with graphics failures in their log will get a partial about:support display.

Is this code covered by automated tests?

No

Has the fix been verified in Nightly?

No

Needs manual test from QE?

Yes

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

The fix for this issue is quite simple. Any remaining properties of the graphics object were being iterated and displayed. The failures property gets displayed by earlier code but was not deleted afterwards, thus the failures property was attempted to print again to the Graphics section, though this secondary callsite did not know how to properly display the failures property. The attached patch deletes the property after it is used the first time thus preventing the issue from occurring.

String changes made/needed

Attachment #9040585 - Flags: approval-mozilla-beta?
Flags: qe-verify+
Whiteboard: [qa-triaged]

I have managed to reproduce this issue on an affected Firefox 66.0a1 (20190121175139) build using Windows 10x64 by changing the "gfx.webrender.all" from about:config to true.

This issue is verified fixed using Firefox 67.0a1 (20190211092917) on Windows 10 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment on attachment 9040585 [details]
Bug 1521599 - Delete the failures data after it has been output. r?Gijs

Verified in nightly, OK for beta uplift.

Attachment #9040585 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This is verified fixed on Firefox 66.0b7 too, using Windows 10 x64.

QA Whiteboard: [qa-triaged]
Whiteboard: [qa-triaged]
You need to log in before you can comment on or make changes to this bug.