Add profiler labels for some font searching functions

RESOLVED FIXED in Firefox 66

Status

()

enhancement
P3
normal
RESOLVED FIXED
7 months ago
7 months ago

People

(Reporter: mstange, Assigned: mstange)

Tracking

(Blocks 1 bug)

Trunk
mozilla66
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 fixed)

Details

Attachments

(1 attachment)

These should aid in tracking down performance problems caused by font enumeration, such as bug 1519513.

Pushed by mstange@themasta.com:
https://hg.mozilla.org/integration/autoland/rev/681241586ba5
Add profiler labels to gfxMacFontFamily::FindStyleVariations and gfxFontFamily::FindFontForChar. r=jfkthame
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
https://hg.mozilla.org/projects/cedar/rev/681241586ba55ad09e9714f9939bbbfa1a9a1c41
Bug 1521622 - Add profiler labels to gfxMacFontFamily::FindStyleVariations and gfxFontFamily::FindFontForChar. r=jfkthame
You need to log in before you can comment on or make changes to this bug.