Update Danawa search URL on Firefox for Android

RESOLVED FIXED

Status

()

RESOLVED FIXED
2 months ago
a month ago

People

(Reporter: hyeonseok, Assigned: delphine)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox65 wontfix, firefox66 fixed, firefox67 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 months ago

This is reported to community forum.

http://forums.mozilla.or.kr/viewtopic.php?p=49335#p49335

Danawa search is not working on Firefox for Android. It seems that they changed the search page URL. It needs to be updated following URL.

http://search.danawa.com/mobile/dsearch.php?keyword={query}&from=firefox

(Reporter)

Comment 1

2 months ago

Francesco, would you please suggest proper assignee for this? (or give a guide if I should do this by myself?)

Flags: needinfo?(francesco.lodolo)

Delphine is in charge of mobile products, redirecting and assigning to her.

Assignee: hyeonseok → lebedel.delphine
Flags: needinfo?(francesco.lodolo) → needinfo?(lebedel.delphine)

Thanks for surfacing this. I'll take a look at this probably early next week!

Heads-up that this hasn't fallen off my radar - I just need to regain Mercurial access first (opened bug for that)

(In reply to Hyeonseok Shin from comment #0)

This is reported to community forum.

http://forums.mozilla.or.kr/viewtopic.php?p=49335#p49335

Danawa search is not working on Firefox for Android. It seems that they changed the search page URL. It needs to be updated following URL.

http://search.danawa.com/mobile/dsearch.php?keyword={query}&from=firefox

Are you sure this is the correct link? It seems weird to me that it would contain "keyword={query}&from=firefox" for example. I've tried playing around with other links but really unsure what it should be.

To give you an idea, the current file points to two links:

Please let me know what the search URL should be, and if the 2nd link is still valid as well.

Flags: needinfo?(lebedel.delphine) → needinfo?(hyeonseok)
(Reporter)

Comment 6

2 months ago

Parameters are not changed. Only the URL without query string needs to be changed. From "http://m.danawa.com/search/index.html" to "http://search.danawa.com/mobile/dsearch.php". Website link looks OK.

Will this change also apply to iOS? iOS has the same problem.

Flags: needinfo?(hyeonseok)

Comment 8

2 months ago
Pushed by francesco.lodolo@mozillaitalia.org:
https://hg.mozilla.org/integration/autoland/rev/cbc562ba5eec
Update Danawa search URL on Firefox for Android r=flod

Comment 9

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
status-firefox67: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla65

@delphine
Can you verify the searchplugins in the next days (or get help from the community for that) and request uplift to beta?

Flags: needinfo?(lebedel.delphine)

Yes, will do! I'm also checking in about the iOS part, I'll update here once I get a reply. Keeping need info for visibility. thanks!

This seems resolved to me in the latest Nightly.
@Hyeonseok Shin: would you mind testing and confirming it's all good now?

Side-note: I'll have to ask the iOS team to manually update this on their side as well.

Flags: needinfo?(lebedel.delphine) → needinfo?(hyeonseok)
(Reporter)

Comment 13

2 months ago

It's all good on Nightly for Android 67.0a1 (2019-02-08)!

Flags: needinfo?(hyeonseok)
Comment hidden (off-topic)
Comment hidden (off-topic)
Comment hidden (off-topic)
Comment hidden (off-topic)
Component: ko / Korean → General
Product: Mozilla Localizations → Firefox for Android
QA Contact: channy
Target Milestone: mozilla65 → ---

Comment on attachment 9041986 [details]
Bug 1521687 - Update Danawa search URL on Firefox for Android

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

None

User impact if declined

Searchplugin is broken since the provider changed URL

Is this code covered by automated tests?

No

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

Only affecting one non-default searchplugin for one locale (Korean)

String changes made/needed

None

Attachment #9041986 - Flags: approval-mozilla-beta?
status-firefox65: --- → fix-optional
status-firefox66: --- → affected
status-firefox67: fixed → verified

Comment on attachment 9041986 [details]
Bug 1521687 - Update Danawa search URL on Firefox for Android

Fix for search provider URL, verified in Nightly.
Let's uplift for beta 8.

Attachment #9041986 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 20

a month ago
bugherderuplift
status-firefox66: affected → fixed
status-firefox65: fix-optional → wontfix
You need to log in before you can comment on or make changes to this bug.