Closed Bug 1521691 Opened 11 months ago Closed 11 months ago

Move CC_VERSION to python configure

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(firefox66 fixed)

RESOLVED FIXED
mozilla66
Tracking Status
firefox66 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

Details

Attachments

(2 files)

In large parts, it's already there.

The only use in configure itself is for a MSVC version check that is now
always true (we don't accept versions < 19.15 anymore).

The only uses in the build system are in code that could just use
CC_TYPE instead.

which, at this point, is only the AC_SUBST, so we don't even need to
give it to old-configure anymore.

Depends on D17207

Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/cfee3de00f12
Remove _MSC_VER from configure. r=chmanchester
https://hg.mozilla.org/integration/autoland/rev/09e1109d2350
Move the remains of CC_VERSION to python configure. r=chmanchester

Backed out 2 changesets (Bug 1521691) for bustages in clang-plugin.dll CLOSED TREE

https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&selectedJob=223392002&revision=09e1109d23504fbc57c80a8982f88f8d710338bd

https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=223392044&repo=autoland&lineNumber=4677

22:49:12 INFO - clang-cl.exe: warning: unknown argument ignored in clang-cl: '-LIBPATH:z:/build/build/src/clang/lib' [-Wunknown-argument]
22:49:12 INFO - clang-cl.exe: error: no such file or directory: 'clangASTMatchers.lib'
22:49:12 INFO - clang-cl.exe: error: no such file or directory: 'clang.lib'
22:49:12 INFO - clang-cl.exe: error: cannot specify '-Foclang-plugin.dll' when compiling multiple source files
22:49:12 INFO - z:/build/build/src/config/rules.mk:675: recipe for target 'clang-plugin.dll' failed
22:49:12 INFO - mozmake.EXE[5]: *** [clang-plugin.dll] Error 1
22:49:12 INFO - mozmake.EXE[5]: Leaving directory 'z:/build/build/src/obj-firefox/build/clang-plugin'
22:49:12 INFO - z:/build/build/src/config/recurse.mk:74: recipe for target 'build/clang-plugin/host' failed
22:49:12 INFO - mozmake.EXE[4]: *** [build/clang-plugin/host] Error 2
22:49:12 INFO - z:/build/build/src/config/recurse.mk:32: recipe for target 'compile' failed
22:49:12 INFO - mozmake.EXE[3]: *** [compile] Error 2
22:49:12 INFO - z:/build/build/src/config/rules.mk:415: recipe for target 'default' failed
22:49:12 INFO - mozmake.EXE[2]: *** [default] Error 2
22:49:12 INFO - Makefile:190: recipe for target 'profiledbuild' failed
22:49:12 INFO - mozmake.EXE[1]: *** [profiledbuild] Error 2
22:49:12 INFO - client.mk:125: recipe for target 'build' failed
22:49:12 INFO - mozmake.EXE: *** [build] Error 2
22:49:12 INFO - 0 compiler warnings present.
22:49:12 ERROR - Return code: 2
22:49:12 WARNING - setting return code to 2
22:49:12 FATAL - 'mach build -v' did not run successfully. Please check log for errors.
22:49:12 FATAL - Running post_fatal callback...
22:49:12 FATAL - Exiting -1
22:49:12 INFO - [mozharness: 2019-01-22 22:49:12.429000Z] Finished build step (failed)
22:49:12 INFO - Running post-run listener: _parse_build_tests_ccov
22:49:12 INFO - Running post-run listener: _shutdown_sccache
22:49:12 INFO - Running command: ['z:\build\build\src\sccache2\sccache.exe', '--stop-server'] in z:\build\build\src
22:49:12 INFO - Copy/paste: z:\build\build\src\sccache2\sccache.exe --stop-server
22:49:12 INFO - Stopping sccache server...
22:49:13 INFO - error: couldn't connect to server
22:49:13 INFO - caused by: No connection could be made because the target machine actively refused it. (os error 10061)
22:49:13 ERROR - Return code: 2
22:49:13 INFO - Running post-run listener: _summarize
22:49:13 ERROR - # TBPL FAILURE #
22:49:13 INFO - [mozharness: 2019-01-22 22:49:13.443000Z] FxDesktopBuild summary:
22:49:13 ERROR - # TBPL FAILURE #
[taskcluster 2019-01-22T22:49:13.460Z] Exit Code: 4294967295
[taskcluster 2019-01-22T22:49:13.460Z] User Time: 31.25ms
[taskcluster 2019-01-22T22:49:13.460Z] Kernel Time: 15.625ms
[taskcluster 2019-01-22T22:49:13.460Z] Wall Time: 6m57.5942425s
[taskcluster 2019-01-22T22:49:13.460Z] Result: FAILED
[taskcluster 2019-01-22T22:49:13.460Z] === Task Finished ===
[taskcluster 2019-01-22T22:49:13.460Z] Task Duration: 15m9.7265087s

Flags: needinfo?(mh+mozilla)
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a57c4b40b14f
Backed out 2 changesets for bustages in clang-plugin.dll CLOSED TREE

Gah I missed a few _MSC_VER in config.mk and rules.mk.

Flags: needinfo?(mh+mozilla)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/ade025709ebf
Remove _MSC_VER from configure. r=chmanchester
https://hg.mozilla.org/integration/autoland/rev/95d021c3e7e2
Move the remains of CC_VERSION to python configure. r=chmanchester
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
See Also: → 1522761
You need to log in before you can comment on or make changes to this bug.