Crash in OOM | large | mozilla::wr::DisplayListBuilder::DisplayListBuilder()

RESOLVED DUPLICATE of bug 1512519

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 1512519
3 months ago
3 months ago

People

(Reporter: cpeterson, Unassigned)

Tracking

(Blocks 1 bug, {crash})

unspecified
ARM64
Android
Points:
---

Firefox Tracking Flags

(firefox64 disabled, firefox65 disabled, firefox66 affected)

Details

(Whiteboard: [arm64:m4])

(Reporter)

Description

3 months ago

This bug is for crash report bp-70189959-309e-48c0-8fdd-011c20190121.

100% of the DisplayListBuilder crashes are happening on ARM64 Android. I'm not sure why we're OOM'ing on ARM64!

This crash appears to be is a startup crash in the A-C Reference Browser or when opening about:buildconfig.

Top 10 frames of crashing thread:

0 libmozglue.so mozalloc_abort memory/mozalloc/mozalloc_abort.cpp:33
1 libmozglue.so mozalloc_handle_oom memory/mozalloc/mozalloc_oom.cpp:51
2 libxul.so gkrust_shared::oom_hook::hook toolkit/library/rust/shared/lib.rs:253
3 libxul.so rust_oom src/libstd/alloc.rs:137
4 libxul.so alloc::alloc::handle_alloc_error src/liballoc/alloc.rs:230
5 libxul.so wr_state_new liballoc/raw_vec.rs:110
6 libxul.so mozilla::wr::DisplayListBuilder::DisplayListBuilder gfx/webrender_bindings/WebRenderAPI.cpp:651
7 libxul.so mozilla::layers::WebRenderLayerManager::EndTransactionWithoutLayer gfx/layers/wr/WebRenderLayerManager.cpp:260
8 libxul.so nsDisplayList::PaintRoot layout/painting/nsDisplayList.cpp:2631
9 libxul.so nsLayoutUtils::PaintFrame layout/base/nsLayoutUtils.cpp:3788

Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1512519
(Reporter)

Updated

3 months ago
Crash Signature: [@ OOM | large | mozalloc_abort | mozalloc_handle_oom | gkrust_shared::oom_hook::hook]
You need to log in before you can comment on or make changes to this bug.