If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Filters only work on Inbox - need to target any imap folder

RESOLVED DUPLICATE of bug 294632

Status

MailNews Core
Filters
--
enhancement
RESOLVED DUPLICATE of bug 294632
16 years ago
9 years ago

People

(Reporter: Blu3, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Using (Build 06/16 #4) filters only works on the Inbox.  All my mailboxes are
remote imap mailboxes and would appear the same as the Inbox would.  I have only
one filter defined: Using a customized header X-Bmilter, if "=True" exists, then
label message as Spam.

I'd surely like filters to work on all my mailboxes, I have about 30 of them.

Comment 1

16 years ago
filter after the fact will hopefully be made to work on all folders (mailboxes)

*** This bug has been marked as a duplicate of 11033 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

16 years ago
Reopening, see http://bugzilla.mozilla.org/show_bug.cgi?id=11033#c69 and
http://bugzilla.mozilla.org/show_bug.cgi?id=11033#c70
Status: RESOLVED → REOPENED
Depends on: 11033
Resolution: DUPLICATE → ---

Comment 3

16 years ago
Seems like you want some global (cross-account) filter options. See bug 34973
and bug 129883 (and dupe against whichever you like).

Comment 4

16 years ago
It does not seem to me this bug is a dupe of any of those bugs you are mentioning

Comment 5

16 years ago
In particular, with IMAP you may want to think about specifying to which folder
each filter should be applied.
(Reporter)

Comment 6

16 years ago
Indeed, this bug (RFE) doesn't match either bugs in comment 3.  Rather than
bloat bugzilla's tiny lil' db, please read bug 1103, comment 69.

I am:

a) wanting to have a list of filters
b) wanting to apply filters to more than just INBOX
c) wanting to be able to pop up (a) for each mailbox and choose all or individual

This bug isn't about refiltering mailboxes manually or automatically.

Comment 7

15 years ago
Sorry for the spam but do I see this right that this bug is also about filtering
local folders? I thought that this was originally the idea of big 11033 but as
far as I can see this only fixed filtering after the fact on Inboxes.

Comment 8

15 years ago
*** Bug 184080 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
This is to add my vote to enabling filters on whatever folder is currently
selected, or on multiple selected folders, for manual operation. Such
functionality is highly useful for archiving. Currently I have defined archive
filters that move unlabeled messages prior to a selected date to archive folders
in my Local folders, which reside on a removable external drive. I would like to
be able to apply the same filter manually on folders other than Inbox to move
the old messages and make more space available. It would also be useful as a way
to apply multiple filters in succession, by using an empty folder as a temporary
gathering point.
mass re-assign.
Assignee: naving → sspitzer
Status: REOPENED → NEW

Updated

14 years ago
OS: Linux → All
Hardware: PC → All
Product: MailNews → Core

Comment 11

12 years ago
*** Bug 310997 has been marked as a duplicate of this bug. ***

Comment 12

12 years ago
howdy y'all,

[1] request that "priority" be changed.
current = normal
requested = enhancement

[2] request bug title be changed.
- add [RFE] or [ENH]at beginning of title
while it's pro'ly unneeded, it makes the fact that it _is_ an rfe more obvious in bug lists.

- current title is "Filters only work on Inbox"
a more to-the-point title would make this easier to find. something like ...
"[RFE} allow folder[s] as filter match criteria"
"[RFE} allow run-selected-filter-on-[folder-name] to be saved in filter"
"[RFE} allow target folder to be saved in filter"

those are actually slightly different things, but they would each cover this in their own ways. i would prefer the 1st method as it fits more cleanly with the way _i_ think of filtering.

take care,
lee

sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
duping to bug 294632, even though it is newer, because it has all the activity of the past few years.
Severity: normal → enhancement
Status: NEW → RESOLVED
Last Resolved: 16 years ago10 years ago
Resolution: --- → DUPLICATE
Summary: Filters only work on Inbox → Filters only work on Inbox - need to target any imap folder
Duplicate of bug: 294632
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.