RFE: XprintUtil code should be dual-licensed (MPL+X.org)

RESOLVED WONTFIX

Status

Core Graveyard
Printing: Xprint
--
enhancement
RESOLVED WONTFIX
16 years ago
8 years ago

People

(Reporter: Roland Mainz, Assigned: Roland Mainz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

16 years ago
RFE: The XprintUtil code should be dual-licensed (MPL+MIT/X.org)

The problem is that XprintUtils should be integrated into the X COnsortium tree
- and the MPL may cause huge problems.

Since I wrote the code all myself I can (AFAIK) relicense it myself without bug
problems, right ? :)
(Assignee)

Comment 1

16 years ago
Created attachment 87867 [details]
MIT/X.org license (from http://www.x.org/terms.htm)
(Assignee)

Comment 2

16 years ago
The files are gfx/src/xprint/xprintutil.c, gfx/src/xprint/xprintutil.h,
gfx/src/xprint/xprintutil_printtofile.c

I still need a license expert who knows how to nicely plug the license templates
together... CC:'ing gerv for help...
If this were going to have any Mozilla license, it should have the tri-license.
But, because the X license is (I think) compatible with all of the MPL, GPL and
LGPL, it may be acceptable to just use the X license alone. This would be better
than quad-licensed code, certainly. There are some precedents for this, but I
don't know what the policy on creating more of it is.

Hecker and mitchell need to see this. CCing them (I'll also send mail.)

Gerv

Comment 4

16 years ago
This is my opinion; Mitchell's may or may not be different.

For this particular code, which is explicitly intended to be shared with another
project, IMO it would be better just to use the X license by itself. I don't see
any point in imposing an MPL/GPL/LGPL tri-license on code that is intended for
use by XFree86. (IMO this is similar to the case of the JPEG code and similar
code taken from other projects and used in the Mozilla project under a BSD-like
license.)

If you want to put this code into the other-licenses directory that's fine.
However I'm not sure it is absolutely necessary, since the X license imposes so
few requirements and would not affect, e.g., notification requirements when
distributing the over Mozilla source.
(Assignee)

Comment 5

16 years ago
hecker wrote:
> For this particular code, which is explicitly intended to be shared with 
> another project, IMO it would be better just to use the X license by itself.
> I don't see any point in imposing an MPL/GPL/LGPL tri-license on code that
> is intended for use by XFree86.

nit: Xfree86!=X.org - X.org is the X Consortium, Xfree86 is a single, tiny
vendor (OKOK, they have a large userbase... :) ... I'd like to contribute the
code to the X.org repository that single vendors like Sun, IBM, Xfree86, etc.
can integrate it into their trees...

> (IMO this is similar to the case of the
> JPEG code and similar code taken from other projects and used in the
> Mozilla project under a BSD-like license.)
>
> If you want to put this code into the other-licenses directory that's fine.
> However I'm not sure it is absolutely necessary, since the X license imposes 
> so few requirements and would not affect, e.g., notification requirements
> when distributing the over Mozilla source.

Uh-oh... sticking it into other-licenses/ will not work...
Mozilla's Xprint module (which builds upon XprintUtils) is build by default on
nearly all Unix platforms since it is the only print module which covers all
i18n requirements (e.g. support for arabic, hebrew, thai, korean, chinese,
japanese, etc.... even MathML(!!) works). Moving the code to other-licenses/
would make it impossible to build it by default - and turning it off in the
default build will IMHO result in a large amounts of complaints by users and
some vendors (incl. Sun and others).

Comment 6

16 years ago
My apologies, I stand corrected re the reference to XFree86. The X.org license
is at <URL:http://www.x.org/terms.htm>; this is the license you want to use,
correct?

I personally am OK with this code going into the main tree under the above
license. But I want to hear Mitchell's opinion as well.

Comment 7

16 years ago
Roland, could you continue to work on this?
Assignee: katakai → Roland.Mainz
QA Contact: Roland.Mainz → katakai
(Assignee)

Comment 8

16 years ago
Frank Hecker wrote:
> My apologies, I stand corrected re the reference to XFree86. The X.org license
> is at <URL:http://www.x.org/terms.htm>; this is the license you want to use,
> correct?

Yes, that's the one I'd like to use (AFAIK it's idetical to the Xfree86 one) ...

Comment 9

16 years ago
[Standard disclaimer: I am not a lawyer, this is not legal advice. This is my
personal opinion.]

OK, based on the comments so far, I think you should license the specified
XPrintUtil files under the X.org license previously referenced, and put them in
the standard Mozilla tree (i.e., *not* in other-licenses), to be built by
default. The copyright holder in the copyright statement should be identified as
Roland Mainz, assuming that you are the only person/entity that contributed to
the files. (In other words, you wrote the code all by yourself and didn't use
any preexisting source files as templates.) If this is not the case, see below.

The license boilerplate would be as follows, as taken from
<http://www.x.org/Downloads_terms.htm> (the former URL
<http://www.x.org/terms.htm> no longer works):

-----

COPYRIGHT AND PERMISSION NOTICE

Copyright (c) 2002 Roland Mainz

All rights reserved.

Permission is hereby granted, free of charge, to any person obtaining a
copy of this software and associated documentation files (the
"Software"), to deal in the Software without restriction, including
without limitation the rights to use, copy, modify, merge, publish,
distribute, and/or sell copies of the Software, and to permit persons
to whom the Software is furnished to do so, provided that the above
copyright notice(s) and this permission notice appear in all copies of
the Software and that both the above copyright notice(s) and this
permission notice appear in supporting documentation.

THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT
OF THIRD PARTY RIGHTS. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR
HOLDERS INCLUDED IN THIS NOTICE BE LIABLE FOR ANY CLAIM, OR ANY SPECIAL
INDIRECT OR CONSEQUENTIAL DAMAGES, OR ANY DAMAGES WHATSOEVER RESULTING
FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION
WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.

Except as contained in this notice, the name of a copyright holder
shall not be used in advertising or otherwise to promote the sale, use
or other dealings in this Software without prior written authorization
of the copyright holder.

X Window System is a trademark of The Open Group.

----

In the above boilerplate I included you as the only copyright holder since you
said you wrote the code all by yourself. If, on the other hand, you based these
files on existing X.org source files then I think you should also retain the
existing copyright notices on the boilerplate along with your own copyright notice:

----

COPYRIGHT AND PERMISSION NOTICE

Copyright (c) 2002           Roland Mainz
Copyright (c) 1999,2000,2001 Compaq Computer Corporation
Copyright (c) 1999,2000,2001 Hewlett-Packard Company
Copyright (c) 1999,2000,2001 IBM Corporation
Copyright (c) 1999,2000,2001 Hummingbird Communications Ltd.
Copyright (c) 1999,2000,2001 Silicon Graphics, Inc.
Copyright (c) 1999,2000,2001 Sun Microsystems, Inc.
Copyright (c) 1999,2000,2001 The Open Group

All rights reserved.

Permission is hereby granted, ...

----

If this advice is acceptable to you please resolve the bug as fixed.
Product: Core → Core Graveyard

Comment 10

8 years ago
This code was removed from the tree in bug 326716.  Does anyone still care about its licensing status?
If we aren't shipping it, then no :-)

Gerv
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.