Closed Bug 1522019 Opened 1 year ago Closed 1 year ago

Google search engine has disappeared from search options which makes Bing the default

Categories

(Firefox :: Search, defect, P1, blocker)

60 Branch
defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr60 65+ verified
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected

People

(Reporter: dev-null, Assigned: mkaply)

References

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0

Steps to reproduce:

  1. Install http://ftp.mozilla.org/pub/firefox/candidates/60.5.0esr-candidates/build1/win32/en-GB/Firefox%20Setup%2060.5.0esr.exe
    (not en-US)
  2. Start Firefox
  3. Go to Tools -> Options -> Search

Actual result:
Google does not appear and Bing is default.

Expected result:
Google exists.

I think this should block 60.5 ESR release.

This doesn't reproduce with en-US, but does with en-GB. Agreed that this blocks the 60.5.0esr release. We'll also need to verify that the Fx65 RC is unaffected.

Flags: needinfo?(mozilla)
Severity: major → blocker
Priority: -- → P1

I've downloaded Beta en-GB, it updated automatically to 65.0, and I don't see problems with Google.

Bug 1510296 recently landed in ESR, and needed a rebase for that, but I can't spot anything wrong with it.
https://hg.mozilla.org/releases/mozilla-esr60/rev/acf00cfc7227

Note that I can reproduce on the Italian build, so it's not just one locale.

I tried to install the google-b-e.xml file in ESR and it works as expected, so that doesn't seem to be the problem.

The problem is that the new ESR engines aren't getting packaged in other locales.

ESR doesn't have our new "include all search plugins"

At this point, we should just back out my ESR changes and I'll do something better next time around.

Flags: needinfo?(mozilla)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Thanks for testing this and the quick report!

Assignee: nobody → mozilla

We have managed to reproduce this issue using Firefox 60.5.0esr (BuildId:20190121141556) build 1.

We have included a test to catch this for our 60.5.0esr (BuildId:20190124141046) build 2 sign-off. Verified fixed using Windows 10 64bit, Windows 7 64bit, macOS 10.13 and Ubuntu 18.04 64bit with de, it, en-GB and en-US locales.

Status: RESOLVED → VERIFIED

This also happened for Fennec nightly in December (bug 1516028).

You need to log in before you can comment on or make changes to this bug.