Closed Bug 1522043 Opened 2 years ago Closed 2 years ago

[remote-dbg-next] Inspecting local addons should use a profile suited to addon developers

Categories

(DevTools :: about:debugging, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1525533

People

(Reporter: jdescottes, Unassigned)

References

Details

(Spawned from Bug 1521486)

When inspecting local addons, we have to use a separate Firefox instance, running with a separate profile, because addons are running in the main process and to debug this main process, we should be in another instance of Firefox.

To do that we reused the toolbox-process-window, but this was originally intended for Firefox UI developers. It is normally used for the Browser Toolbox. And it creates a default profile with a set of preferences that can be confusing to addon developers: https://searchfox.org/mozilla-central/rev/6c784c93cfbd5119ed07773a170b59fbce1377ea/devtools/client/framework/toolbox-process-window.js#103-114

We should use another profile when we want to debug addons, that doesn't show unnecessary Firefox internals to the developer.

Priority: -- → P3

This will be solved by Bug 1525533

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1525533
No longer blocks: remote-debugging-ng-m2
You need to log in before you can comment on or make changes to this bug.