Closed Bug 1522207 Opened 10 months ago Closed 5 months ago

[meta] Full page colour contrast audit

Categories

(DevTools :: Accessibility Tools, enhancement)

enhancement
Not set

Tracking

(relnote-firefox 68+)

RESOLVED FIXED
Tracking Status
relnote-firefox --- 68+

People

(Reporter: yzen, Assigned: yzen)

References

Details

(Keywords: dev-doc-complete, meta)

Attachments

(1 file)

In addition to providing colour contrast information for individual nodes/accessible objects, a11y panel should also have a display mode that shows all colour contrast accessibility issues on the page.

Summary: Full page colour contrast audit → [meta] Full page colour contrast audit
Duplicate of this bug: 1536802
Duplicate of this bug: 1536801
Depends on: 1536802
Depends on: 1538281
Depends on: 1538306
Depends on: 1539231
QA Contact: timea.babos
Depends on: 1540601
Depends on: 1540904
Depends on: 1541666
Depends on: 1543667
Depends on: 1544678
Depends on: 1544684
Depends on: 1544690
Depends on: 1544700
Depends on: 1544710
Depends on: 1544711
Depends on: 1544713
Depends on: 1544714
Depends on: 1544728
Depends on: 1544733
Attachment #9059165 - Flags: ui-review?(victoria)
Depends on: 1545734
Keywords: dev-doc-needed
Depends on: 1546081
Depends on: 1546084
Comment on attachment 9059165 [details]
UX Spec to help with ui review.

Hi Yura,

This looks great, and is so exciting!

The only thing I noticed that seemed odd is how the contrast badges inside the tree work the same way as the top one.  I would expect the node badges to do some action on the node only. I'd suggest keeping just the toolbar badge as a functional filter button, and make the other badges the unclickable (no background) style.
Depends on: 1547068
Depends on: 1548241
Depends on: 1548262
Attachment #9059165 - Flags: ui-review?(victoria)

Is this something we should mention in the 68 release notes? If yes can you suggest some wording?

Flags: needinfo?(yzenevich)
No longer depends on: 1548262

(In reply to Julien Cristau [:jcristau] from comment #5)

Is this something we should mention in the 68 release notes? If yes can you suggest some wording?

It's in Firefox and Runtime Visuals trello boards. I'm not sure if things that are marked as ready to land there get into release notes automatically, if not, hopefully, I can defer that to Martin or Asa.

Flags: needinfo?(yzenevich)
Flags: needinfo?(mbalfanz)
Flags: needinfo?(asa)

Yes, this should be a part of the release notes.

Flags: needinfo?(asa)

Release Note Request (optional, but appreciated)
[Why is this notable]:
[Affects Firefox for Android]:
[Suggested wording]:
[Links (documentation, blog post, etc)]:

Potential Release Note:

In addition to providing color contrast information for individual elements of a page, Firefox now offers a full page color contrast audit that identifies all element on a page that fail color contrast checks.

Definitely relevant for the release notes, though I was also under the impression that features tracked in the R&V trello board are tracked for relnotes automatically 🤔

I'll clarify with Thomas for the next time.

Flags: needinfo?(mbalfanz)

Thanks Asa, added to the beta release notes.

FWIW this is not automatic. If something is in the Firefox (not R&V) trello board it'll be picked up (which is how I came here), but I prefer to ask the people who know what the feature is about for some wording and/or relevant links, hence this request here.

Depends on: 1556135
Depends on: 1552142
Depends on: 1558188
Depends on: 1558194
Depends on: 1558422
Depends on: 1559316
Depends on: 1559317
No longer depends on: 1558422
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
No longer depends on: 1544711, 1544728, 1544733, 1545734, 1552142
Resolution: --- → FIXED

Closed since follow up work will happen in individual bugs.

This is tracked on GitHub in MDN/Sprints #1772

Added a section showing the check for contrast issues with the comment that more accessibility problems will be added in the future.

Accessibility Inspector Find contrast issues

Please let me know if this is enough for now.

This weeks tool tip for the Newsletter will cover this new feature

The Accessibility Inspector page as a whole needs an update, but perhaps when we start documenting 69?

Flags: needinfo?(yzenevich)

(In reply to Irene Smith from comment #13)

Added a section showing the check for contrast issues with the comment that more accessibility problems will be added in the future.

Accessibility Inspector Find contrast issues

Please let me know if this is enough for now.

This weeks tool tip for the Newsletter will cover this new feature

The Accessibility Inspector page as a whole needs an update, but perhaps when we start documenting 69?
Yeah that would be fantastic.

Flags: needinfo?(yzenevich)
You need to log in before you can comment on or make changes to this bug.