Closed Bug 1522249 Opened 4 years ago Closed 3 years ago

ARM64: Crash in atomics/basic-tests.js

Categories

(Core :: JavaScript Engine: JIT, defect, P2)

ARM64
Unspecified
defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- fixed

People

(Reporter: sstangl, Assigned: sstangl)

References

(Blocks 1 open bug)

Details

(Keywords: crash, Whiteboard: [arm64:m3])

Attachments

(1 file)

When run on ARM64 hardware, this test fails: atomics/basic-tests.js

The arguments passed are as follows:

--baseline-eager atomics/basic-tests.js
--ion-eager --ion-offthread-compile=off --more-compartments atomics/basic-tests.js
--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads atomics/basic-tests.js

The crash signature is as follows:

Hit MOZ_CRASH(NYI) at /home/sstangl/dev/gecko-dev/js/src/jit/arm64/Lowering-arm64.cpp:376

That line number corresponds to LIRGenerator::visitCompareExchangeTypedArrayElement.

See Also: → 1522254

[arm64:m3] because we should fix reproducible test crashes before letting ARM64 Fennec Nightly ride the trains to Beta.

Keywords: crash
Whiteboard: [arm64:m3]
Assignee: nobody → sstangl
Status: NEW → ASSIGNED

ARM64: Pass atomics/basic-tests.js. Reuses existing code paths.

Duplicate of this bug: 1522259
Pushed by sstangl@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/12ad58f88888
ARM64: Pass atomics/basic-tests.js. r=nbp
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.