submission of form in linuxconf doesn't work

RESOLVED INVALID

Status

()

RESOLVED INVALID
17 years ago
16 years ago

People

(Reporter: pcrooker, Assigned: alexsavulov)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
When trying to update a user's password I click on the usr1 submit button (see
at the bottom of the table) which should return a password fill-in form.
Instead, it just returns to the next higher level of linuxconf (Networking /
sendmail / virtual POP accounts / xxx.yyy.com) with the correct URL though (ie
the URL pointing to the user's detail page. If I use Netscape 4.76 it works.
This fails on 0.9.7, 0.9.9 and 1.0 on Linux and 1.0 on Windows.

I can't find exactly what is going on cause linuxconf seems to use its own
webserver with embedded pages, etc.

cheers, Phil


<form method=post
action=/html:/ok,==Networking/ok,==Mail==delivery==system==(sendmail)/ok,==Virtual==POP==accounts==(mail==only)/ok,xxx.yyy.com/ok,jbloggs/>
<center>
<table border=0>
<tr><td><th colspan=10 align=center bgcolor="#000066"><font
color="#ffffff"><strong>Base info</strong></font>
<tr><td><td><input type=checkbox name="5_The==account==is==enabled-1"
value="yes" checked>
The account is enabled
<input type=hidden name="5_CUR_The==account==is==enabled-1" value="yes">
<tr><td>Login name<td><input type=text name="5_Login==name-2" value="jbloggs"
size=30 maxlength=256>

<input type=hidden name="5_CUR_Login==name-2" value="jbloggs">
<tr><td>Full name<td><input type=text name="5_Full==name-3"
value="Ashley&nbsp;Smith" size=30 maxlength=256>
<input type=hidden name="5_CUR_Full==name-3" value="Joseph&nbsp;bloggs">
<tr><td>group<td>popusers
<tr><td>Home directory(opt)<td><input type=text name="5_Home==directory(opt)-5"
value="/vhome/xxx.yyy.com/home/jbloggs" size=30 maxlength=256>
<input type=hidden name="5_CUR_Home==directory(opt)-5"
value="/vhome/xxx.yyy.com/home/jbloggs">
<tr><td>User ID(opt)<td><input type=text name="5_User==ID(opt)-6" value="60001"
size=30 maxlength=256>
<input type=hidden name="5_CUR_User==ID(opt)-6" value="60001">
<tr><td><th colspan=10 align=center bgcolor="#000066"><font
color="#ffffff"><strong>Password management</strong></font>
<tr><td>Last password change<td>2002/06/16
<input type=hidden name="5_CUR_Must==keep==#==days-9" value="-1">

<tr><td>Must keep # days<td><input type=radio name="5_Must==keep==#==days-9"
value="0" checked>
		Ignored
<input type=hidden name="5_CUR_Must==keep==#==days-9" value="0">
<input type=radio name="5_Must==keep==#==days-9" value="1" >
<input type=text name="5_Must==keep==#==days-9-s" value="" size=10>
<tr><td>Must change after # days<td><input type=integer
name="5_Must==change==after==#==days-10" value="99999" size=10 maxlength=20>
<input type=hidden name="5_CUR_Must==change==after==#==days-10" value="99999">
<input type=hidden name="5_CUR_Warn==#==days==before==expiration-11" value="-1">
<tr><td>Warn # days before expiration<td><input type=radio
name="5_Warn==#==days==before==expiration-11" value="0" checked>
		Ignored
<input type=hidden name="5_CUR_Warn==#==days==before==expiration-11" value="0">
<input type=radio name="5_Warn==#==days==before==expiration-11" value="1" >

<input type=text name="5_Warn==#==days==before==expiration-11-s" value="" size=10>
<input type=hidden name="5_CUR_Account==expire==after==#==days-12" value="-1">
<tr><td>Account expire after # days<td><input type=radio
name="5_Account==expire==after==#==days-12" value="0" checked>
		Ignored
<input type=hidden name="5_CUR_Account==expire==after==#==days-12" value="0">
<input type=radio name="5_Account==expire==after==#==days-12" value="1" >
<input type=text name="5_Account==expire==after==#==days-12-s" value="" size=10>
<tr><td>Expiration date (yyyy/mm/dd)<td><input type=text
name="5_Expiration==date==(yyyy==mm==dd)-13" value="" size=30 maxlength=256>
<input type=hidden name="5_CUR_Expiration==date==(yyyy==mm==dd)-13" value="">
<tr><td><th colspan=10 align=center bgcolor="#000066"><font
color="#ffffff"><strong>Mail settings</strong></font>
<input type=hidden name="5_CUR_Inbox==max.==size(k)-15" value="0">
<tr><td>Inbox max. size(k)<td><input type=radio name="5_Inbox==max.==size(k)-15"
value="0" checked>

		Domain default
<input type=hidden name="5_CUR_Inbox==max.==size(k)-15" value="0">
<input type=radio name="5_Inbox==max.==size(k)-15" value="1" >
<input type=text name="5_Inbox==max.==size(k)-15-s" value="" size=10>
<tr><td>Redirect messages to<td><input type=text
name="5_Redirect==messages==to-16" value="" size=30 maxlength=256>
<input type=hidden name="5_CUR_Redirect==messages==to-16" value="">
<tr><td>Email alias<td><input type=text name="5_Email==alias-17"
value="joseph.bloggs" size=30 maxlength=256>
<input type=hidden name="5_CUR_Email==alias-17" value="joseph.bloggs">
<tr><td><td><input type=text name="5_-18" value="" size=30 maxlength=256>
<input type=hidden name="5_CUR_-18" value="">
<tr><td><td><input type=text name="5_-19" value="" size=30 maxlength=256>
<input type=hidden name="5_CUR_-19" value="">
<tr><td><td><input type=text name="5_-20" value="" size=30 maxlength=256>
<input type=hidden name="5_CUR_-20" value="">

</table>
</center>
<p>
<input type=image name=accept border=0 src="/images:images/Accept.png" ALT="Accept">
<input type=image name=del border=0 src="/images:images/Del.png" ALT="Del">
<input type=image name=usr1 border=0 src="/images:images/Passwd.png" ALT="Passwd">
<a href="/help:help.eng/userconf/user.html" target="_blank"><img border=0
src="/images:images/Help.png" ALT="Help"></a>
</form>

Comment 1

17 years ago
this code is very confusing... when I submit using the button I get the
following url:
http://bubblegum/html:/ok,==Networking/ok,==Mail==delivery==system==(sendmail)/ok,==Virtual==POP==accounts==(mail==only)/ok,xxx.yyy.com/ok,jbloggs/

(bubblegum is the server I'm running on) This doesnt look like a valid url to me.. 

Please use some software to view what is sent over the HTTP protocall and attach
the logs both from Mozilla and from Netscape 4.x.

Comment 2

17 years ago
..asking linuxconf@hub.xc.org for help with this one
OS: Linux → All

Comment 3

16 years ago
resolving invalid due to lack of responce from reporter
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.