Closed Bug 1522268 Opened 11 months ago Closed 11 months ago

ARM64: Crash in basic/bug570663-2.js

Categories

(Core :: JavaScript Engine: JIT, defect, P2)

ARM64
Unspecified
defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- wontfix
firefox67 --- fixed

People

(Reporter: sstangl, Assigned: nbp)

References

(Blocks 1 open bug)

Details

(Keywords: crash, Whiteboard: [arm64:m3])

Attachments

(1 file)

When run on ARM64 hardware, this test fails: basic/bug570663-2.js

The arguments passed are as follows:

--ion-eager --ion-offthread-compile=off --more-compartments basic/bug570663-2.js
--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads basic/bug570663-2.js

The crash signature is as follows:

Assertion failure: MIR instruction returned value with unexpected type, at /home/sstangl/dev/gecko-dev/js/src/jit/MacroAssembler.cpp:2013

[arm64:m3] because we should fix reproducible test crashes before letting ARM64 Fennec Nightly ride the trains to Beta.

Keywords: crash
Whiteboard: [arm64:m3]
Assignee: nobody → nicolas.b.pierron
Status: NEW → ASSIGNED
Pushed by npierron@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/614a820c5bb1
ARM64: MoveOP::Int32 should load 32 bits values after breaking cycles. r=sstangl
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.