Closed Bug 1522276 Opened 11 months ago Closed 11 months ago

ARM64: Crash in ion/bug898857.js

Categories

(Core :: JavaScript Engine: JIT, defect, P2)

ARM64
Unspecified
defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox-esr60 --- wontfix
firefox64 --- wontfix
firefox65 --- wontfix
firefox66 --- disabled
firefox67 --- fixed

People

(Reporter: sstangl, Assigned: nbp)

References

(Blocks 1 open bug)

Details

(Keywords: crash, Whiteboard: [arm64:m3])

Attachments

(1 file)

When run on ARM64 hardware, this test fails: ion/bug898857.js

The arguments passed are as follows:

--ion-eager --ion-offthread-compile=off --more-compartments ion/bug898857.js

The crash signature is as follows:

Hit MOZ_CRASH(lowerUDiv) at /home/sstangl/dev/gecko-dev/js/src/jit/arm64/Lowering-arm64.cpp:314

[arm64:m3] because we should fix reproducible test crashes before letting ARM64 Fennec Nightly ride the trains to Beta.

Keywords: crash
Whiteboard: [arm64:m3]
Assignee: nobody → nicolas.b.pierron
Status: NEW → ASSIGNED
Pushed by npierron@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6785ac75ef26
IonMonkey ARM64: Add generic UDiv implementation. r=sstangl
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.