Closed Bug 1522315 Opened 10 months ago Closed 10 months ago

“Allow Location Access” button in location permission prompt is truncated in French

Categories

(Toolkit :: Themes, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla66
Tracking Status
firefox-esr60 --- unaffected
firefox64 --- unaffected
firefox65 --- unaffected
firefox66 --- fixed

People

(Reporter: tchevalier, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image location.png

On macOS, using Nightly 66.0a1 (2019-01-23) (64-bit), “Allow Location Access” button is truncated in French, while it’s displayed correctly on Beta 65.0b12.

Attaching a screenshot of the recent change

Would you mind running mozregression to find the regressing bug?

Thank you!

Flags: needinfo?(theo)

I’m afraid nothing changed in the en-US build, and last time I used mozregression, it was impossible to run it on localized builds. Has this changed?

Flags: needinfo?(theo)

Oh, right, I didn't realize. I don't actually know, maybe I can find the regressor with some investigation instead, thank you anyway :)

Flags: needinfo?(jhofmann)

It's truncated in Italian too. From the image it looks like we added some padding to these buttons, but that makes the label overflow.

From a quick look at the CSS, bug 1518462 might be relevant (removing the margin: 0 removes truncation).
https://searchfox.org/mozilla-central/rev/39265dd58298c40bed029617ad408bf806cce761/toolkit/themes/shared/global.inc.css#64

Flags: needinfo?(jhofmann) → needinfo?(dao+bmo)
Assignee: nobody → dao+bmo
Blocks: 1518462
Component: Device Permissions → Themes
Flags: needinfo?(dao+bmo)
Priority: -- → P1
Product: Firefox → Toolkit
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0f54f0a8fc4a
Reduce minimum horizontal padding for panel footer buttons. r=johannh
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla66
See Also: → 1589646
You need to log in before you can comment on or make changes to this bug.