Thanks Sole, some answers below:
You suggest we disable them using skip-if = serviceworker_e10s. But the tests are specifically written to test the behaviour when e10s is on, changing between single or multiple processes... so I wonder if we should disable them if the new SW implementation is on instead. Something like skip-if = sw_intercept ??
This is exactly what this skip if is doing. It disables the test when running with the refactor.
However I wonder if the name should be a true value and not a negated one, as it makes boolean logic easier to reason about: canDebugServiceWorkers
I would prefer "canDebugServiceWorkers", but I didn't want to force you to "reverse" the logic the logic everywhere, as it means more work :) If you feel like doing it, go for it!
I also don't know if we prefer is* rather than can* in the function naming (maybe there's no explicit style guide).
can* is good here. Otherwise we have to use isServiceWorkerDebuggerEnabled, and that's not even really accurate. The question is not whether some option is toggled to debug service workers, but rather "is it possible at all in this environment". So can* would be a better name.
This would be a little more tedious to implement so I propose it should be a follow up, together with the renaming so it's more atomic, and the code would look much nicer.
I initially assumed this would be tackled a follow up, but again if you feel like doing everything here, it's definitely better ;)