Closed Bug 1522523 Opened 3 years ago Closed 3 years ago

data-list options does not appear

Categories

(Core :: DOM: Core & HTML, defect)

64 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1489440

People

(Reporter: blowfish_blowfish, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0
Firefox for Android

Steps to reproduce:

1- visit any page that contains a data-list for example the data list tag page
https://developer.mozilla.org/en-US/docs/Web/HTML/Element/datalist
the first demo in that page the options does not show (this what happen in my web app)

2- now go to the demo in examples section down the page it will work correctly.

3- now open the developer tools and enable the Responsive Design Mode and try the last example it will not show the options.

so the first demo does not work in all cases the last does not work in case you enabled the responsive design.

now this problem in the desktop version of firefox also happened in the android version of firefox,
the first demo does not work the last one works, now in my web app all the data list in firefox android does not work.
(i do not know where should i report this bug desktop or android)

using any android device visit the same page mentioned above and try the first demo it will not work.

I tried the mentioned page in google chrome and it is working fine.

Please fix this bug because data list is a very important part in my app.

Desktop test spec:
Windows 7 64 bit.
Firefox 64.0.2 (64-bit

Android test spec:
Android 7
Firefox 64.0.2.

Thank you.

Actual results:

the options does not appear

Expected results:

the options should appear

This is funny because the testcase got fixed by bug 1489440 just 2 days ago at least for Desktop.

Fix range:

5:27.32 INFO: First good revision: 605d15524a488ee41d9566f1f48904798cb188a8
5:27.32 INFO: Last bad revision: 22b28921759054aa25d1bc4b78e3a2761af40d81
5:27.32 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=22b28921759054aa25d1bc4b78e3a2761af40d81&tochange=605d15524a488ee41d9566f1f48904798cb188a8

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1489440

(In reply to Matthias Versen [:Matti] from comment #1)

This is funny because the testcase got fixed by bug 1489440 just 2 days ago at least for Desktop.

Fix range:

5:27.32 INFO: First good revision: 605d15524a488ee41d9566f1f48904798cb188a8
5:27.32 INFO: Last bad revision: 22b28921759054aa25d1bc4b78e3a2761af40d81
5:27.32 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=22b28921759054aa25d1bc4b78e3a2761af40d81&tochange=605d15524a488ee41d9566f1f48904798cb188a8

*** This bug has been marked as a duplicate of bug 1489440 ***

Yes.
Now that bug is fixed in FF 66, will that fix be released with the next version which is 65 to be released on Jan 29, 2019 or wait until version 66 gets released on 19 March 2019 ? (i mean will you merge that fix with version 65 because it exist in version 64 or because the bug is fixed in v66 so we wait v66?)

dates reference:
https://wiki.mozilla.org/Releases/Firefox_65
https://wiki.mozilla.org/Releases/Firefox_66

Component: Untriaged → DOM
Product: Firefox → Core

The bug is currently only fixed in Firefox66 (target field and tracking field in bug 1489440)
Firefox65 seems to be already in a "soft freeze" and the fix landed behind that date.
https://wiki.mozilla.org/Release_Management/Calendar

The bug itself is also very likely not critical enough to get uplifted but that is just my opinion as community bug triage guy.
In case you think that it's important enough for an uplift you have to ask the developer directly in bug 1489440.

(In reply to Matthias Versen [:Matti] from comment #3)

I think it is a critical functional bug because the data list is not doing what it should do, it is not a data list because of this bug.

The release date for Firefox66 is 53 days from today i think that is a lot for Firefox64 users, i am going to ask the developer in bug 1489440.

Thank you.

Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.