Closed Bug 1522538 Opened 10 months ago Closed 10 months ago

65.0b10 partials tmp filename collision

Categories

(Release Engineering :: Release Automation: Updates, defect)

defect
Not set

Tracking

(firefox67 fixed)

RESOLVED FIXED
Tracking Status
firefox67 --- fixed

People

(Reporter: mtabara, Assigned: sfraser)

References

Details

(Whiteboard: [releaseduty])

Attachments

(1 file)

2019-01-10 23:57:12,437 - INFO - Checking /tmp/tmpnw1iig3w/from.mar signature
Traceback (most recent call last):
File "/home/worker/bin/funsize.py", line 513, in <module>
main()
File "/home/worker/bin/funsize.py", line 487, in main
manifest = loop.run_until_complete(async_main(args, signing_certs))
File "/usr/lib/python3.6/asyncio/base_events.py", line 473, in run_until_complete
return future.result()
File "/home/worker/bin/funsize.py", line 431, in async_main
manifest = await asyncio.gather(tasks)
File "/home/worker/.local/share/virtualenvs/-x-v5uFv0/lib/python3.6/site-packages/scriptworker/utils.py", line 260, in retry_async
return await func(args, **kwargs)
File "/home/worker/bin/funsize.py", line 311, in manage_partial
await unpack(work_env, dest, unpack_dir)
File "/home/worker/bin/funsize.py", line 172, in unpack
os.mkdir(dest_dir)
FileExistsError: [Errno 17] File exists: '/tmp/tmpnw1iig3w/from'

More here

Duplicate of this bug: 1519843

I think this happens when the download at https://searchfox.org/mozilla-central/source/taskcluster/docker/funsize-update-generator/scripts/funsize.py#315 fails. This raises an exception which causes manage_partial() to be re-tried. However, at this point the work_env isn't empty.

Perhaps the call to work_env.setup() should be moved into manage_partial(), while also ensuring that the work environment is clean?

Flags: needinfo?(sfraser)
Assignee: nobody → sfraser
Flags: needinfo?(sfraser)

Ensure the working area on disk is set up for each unique partials generation call, to avoid re-using a broken area in retries.

Is this ready to land?

Yes, apologies for not landing it straight after review, I wanted to make sure I could watch the results.

Pushed by sfraser@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d05a4215065d
Adjust working area setup for partials r=mtabara
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.