Closed Bug 1522571 Opened 11 months ago Closed 3 months ago

Move AddonTargetFront outside of devtools/shared/front/targets

Categories

(DevTools :: Framework, enhancement, P1)

enhancement

Tracking

(firefox70 fixed)

RESOLVED FIXED
Firefox 70
Tracking Status
firefox70 --- fixed

People

(Reporter: ochameau, Assigned: yulia)

References

(Blocks 1 open bug)

Details

(Whiteboard: dt-fission)

Attachments

(1 file)

This class is no longer a Target class. Instead, its connect() method allows returning one.
So that this class no longer belongs to the targets directory.

This might be described as a descriptor?

Assignee: nobody → ystartsev
Priority: P2 → P1
Status: NEW → ASSIGNED

It turns out that the "addonTargetFront" was being used by the "WebExtensionActor". I aligned the naming and changed the spec to reflect the relationship between these two -- which has no attach, detach, reconfigure methods as mentioned by alex. Ultimately, this should probably be turned into a descriptor class.

Blocks: 1575557
Pushed by ystartsev@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/586631218ed0
Unify addonTargetFront with webExtensionSpec; r=ochameau
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 70
Regressions: 1578108
You need to log in before you can comment on or make changes to this bug.