Closed Bug 1522584 Opened 2 years ago Closed 2 years ago

nsIToolkitProfile.removeInBackground(true) asserts in debug builds

Categories

(Toolkit :: Startup and Profile System, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
Tracking Status
firefox67 --- wontfix
firefox68 --- fixed

People

(Reporter: mossop, Assigned: mossop)

References

Details

Remove in background takes a lock on the profile folder and then runs a task on the stream transport thread. When the task unlocks the lock it releases a reference to the profile on the thread, and the profile isn't declared as thread safe so we assert.

Duplicate of this bug: 1533626

Will be fixed by bug 1529879

Depends on: 1529879
Priority: -- → P3
Assignee: nobody → dtownsend
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1465545
You need to log in before you can comment on or make changes to this bug.