Closed Bug 1522659 Opened 2 years ago Closed 1 year ago

Pressing escape when editing a preference in the new about:config should abandon editing

Categories

(Toolkit :: Preferences, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- disabled
firefox66 --- unaffected
firefox67 --- disabled
firefox68 --- disabled
firefox69 --- disabled
firefox70 --- disabled
firefox71 --- fixed

People

(Reporter: mossop, Assigned: jawad)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

If I start to edit a string value and want to cancel I press escape. Nothing happens. It would be nice if this undid my edits.

Also, or alternatively, a "Cancel" button could appear next to the "Save" button, to allow me to dismiss the edit box without saving my changes.

It turns out that clicking "Edit" on a different preference will have this effect: it dismisses the current edit box without saving changes. But this is non-obvious: I wasn't at all sure it would be possible to start editing a new preference without first saving the current one, and I certainly couldn't tell in advance whether doing so would or would not save the edited value of the current one.

To put things in perspective, most edits of text fields would be from "0" to "1" or similar.

We're not really concerned about making this the best user interface possible, it just has to be good enough to allow people to perform the task.

That said, canceling the edit when pressing ESC would be a nice to have, I think we could accept a patch to do that with a specific regression test. This isn't high priority because a workaround to get rid of a stray click on an edit button would be to just search again or reload the page, clicking Save without modifying the value, or use the Undo command in the textbox.

Priority: -- → P5
Summary: Pressing escape when editing a preference in the new about:config should abandon editing. → Pressing escape when editing a preference in the new about:config should abandon editing
Blocks: 1493439
Duplicate of this bug: 1523060
Duplicate of this bug: 1524153

Hi, I am willing to work on this, please assign it to me.

Flags: needinfo?(enndeakin)

Thanks for working on this! As noted in the review, this requires a test case to be written. If you have a mentor, they can help you with it.

Flags: needinfo?(enndeakin)

New about:config is not by default in 67 -> disabled.

Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/65435277ebd7
Cancel editing a pref with escape in about:config r=jaws,paolo
Backout by csabou@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f5dd266a1d04
Backed out 2 changesets (bug 1522659, bug 1553624) for browser chrome failures on browser_edit.js. CLOSED TREE
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90984e8cdaec
Cancel editing a pref with escape in about:config r=jaws,paolo
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Flags: needinfo?(mstriemer)
You need to log in before you can comment on or make changes to this bug.