Closed Bug 1522755 Opened 8 months ago Closed 8 months ago

Ship eBay Scroll Anchoring intervention to Fennec

Categories

(Web Compatibility :: Interventions, defect)

defect
Not set

Tracking

(firefox66 verified, firefox67 verified)

VERIFIED FIXED
Tracking Status
firefox66 --- verified
firefox67 --- verified

People

(Reporter: denschub, Assigned: denschub)

References

Details

Attachments

(2 files)

Attached file GitHub Pull Request

To fix the scroll anchoring issues for eBay that have been discovered in bug 1520666, let's ship an intervention to address that issue, which allows us to turn scroll anchoring back on in Fennec.

Blocks: 1522964
Attachment #9039021 - Attachment description: Bug 1522755 - Ship eBay Scroll Anchoring intervention to Fennec. → Bug 1522755 - Ship eBay Scroll Anchoring intervention to Fennec. r=rhelmer

Daniel Holbert had a great point that this should probably apply to more ebay domains.

See bug 1520666 comment 28.

Flags: needinfo?(dschubert)

Yup, Dennis is already on top of this, per discussion in phabricator.

Flags: needinfo?(dschubert)

Awesome, thanks!

Pushed by mitaylor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/560f47e59a0f
Ship eBay Scroll Anchoring intervention to Fennec. r=rhelmer
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED

Let's reopen this, so we can request beta uplift in a day. (Sorry, should have set leave-open :))

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment on attachment 9039021 [details]
Bug 1522755 - Ship eBay Scroll Anchoring intervention to Fennec. r=rhelmer

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

Bug 1515946

User impact if declined

Without this patch, we will not be able to enable Scroll Anchoring for Firefox for Android users, because it breaks scrolling on eBay properties (see bug 1520666)

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

We already have other GoFaster site interventions landed in both Desktop and Fennec, so we know that the source itself works. The patch in question only applies to eBay domains, and is designed in a way that only changes things if needed. In the worst case where the content script provided in this test throws an exception, the site itself shouldn't be affected.

String changes made/needed

Attachment #9039021 - Flags: approval-mozilla-beta?

You don't have to leave a bug open for us to uplift. Actually, we'll notice it from both the uplift request, and from the fact of a fixed bug having the status-firefox66 flag set to affected or to nothing.

Comment on attachment 9039021 [details]
Bug 1522755 - Ship eBay Scroll Anchoring intervention to Fennec. r=rhelmer

Fix for popular site, let's uplift for beta 4.
Sorina, can your team verify the fix in beta once it's in? Thanks.

Flags: needinfo?(sorina.florean)
Attachment #9039021 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → FIXED

Hi Liz,
I was able to reproduce the issue from bug 1520666 using an affected build with Samsung Galaxy Note 8(8.0.0). I can confirm that the issue is not reproducible on Nightly 67.0a1 - 01/31 following the same steps. I will leave the needinfo to verify once we have the beta build.

Hello,
I can confirm that the issue is not reproducible anymore on Beta 66.0b5 using OnePlus 5T (Android 9) and Google Pixel (Android 9).

Status: RESOLVED → VERIFIED
Flags: needinfo?(sorina.florean)
See Also: → 1529765
You need to log in before you can comment on or make changes to this bug.