microsoft.com - ASP.NET Request.Browser.Browser reports Mozilla incorrectly

RESOLVED INVALID

Status

Tech Evangelism Graveyard
English US
--
major
RESOLVED INVALID
16 years ago
3 years ago

People

(Reporter: Russell Odom, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

Using Mozilla 1.0 to access an ASP.NET page, using the inbuilt
Request.Browser.Browser object, it reports my browser as Netscape 5.0

Reproducible: Always
Steps to Reproduce:
Will attach a test ASP.NET page

Actual Results:  Reports browser as Netscape 5.0

Expected Results:  Should report browser as Mozilla 1.0

Haven't tried it NS6 or 7, but I guess they may be wrong too. Severity Major,
since this is a product that is likely to come into massive use. Not sure on the
chances of getting MS to fix it though :-)
(Reporter)

Comment 1

16 years ago
Created attachment 87919 [details]
Test ASP.NET page showing problem

You'll need to install this page on a Microsoft server to get it to work

Comment 2

15 years ago
The problem is in the <browserCaps> section of machine.config and/or web.config.

Here are some of the problems: Mozilla is detected as "Netscape5"; the value
Request.Browser.W3CDomVersion is set to 0.0; when given a choice between HTML
and CSS, HTML is used (for IE CSS is used).

There is a partial fix at
http://www.dwfaq.com/Snippets/snippet_details.asp?SnipID=360.

Comment 3

15 years ago
tech evang june 2003 reorg
Assignee: doron → english-us
QA Contact: zach → english-us

Updated

15 years ago
Summary: ASP.NET Request.Browser.Browser reports Mozilla incorrectly → microsoft.com - ASP.NET Request.Browser.Browser reports Mozilla incorrectly

Comment 4

4 years ago
10 years old bug. Cleaning spree.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.