Intermittent browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | A promise chain failed to handle a rejection: this._remotenessChangingBrowsers.get(...) is undefined - stack: _asyncNavigateAndRestore@resource

VERIFIED FIXED in Firefox 66

Status

()

P5
normal
VERIFIED FIXED
2 months ago
a month ago

People

(Reporter: intermittent-bug-filer, Assigned: Nika)

Tracking

({intermittent-failure})

unspecified
Firefox 67
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox66 fixed, firefox67 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 months ago
treeherder

#[markdown(off)]
Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=224020234&repo=autoland

https://queue.taskcluster.net/v1/task/NRmUjeBfToWz6nYxx-gPPQ/runs/0/artifacts/public/logs/live_backing.log

14:03:47 INFO - TEST-PASS | browser/components/urlbar/tests/legacy/browser_tabMatchesInAwesomebar.js | http://example.com/browser/browser/components/urlbar/tests/legacy/dummy_page.html#tabmatch16 was found in autocomplete, was expected -
14:03:47 INFO - Searching open pages.
14:03:47 INFO - Found 3 matches.
14:03:47 INFO - Skip heuristic match
14:03:47 INFO - Search for 'data:text/html,<body><iframe src=""></iframe></body>' in open tabs.
14:03:47 INFO - TEST-PASS | browser/components/urlbar/tests/legacy/browser_tabMatchesInAwesomebar.js | data:text/html,<body><iframe src=""></iframe></body> was found in autocomplete, was expected -
14:03:47 INFO - Search for 'http://example.com/browser/browser/components/urlbar/tests/legacy/dummy_page.html#tabmatch16' in open tabs.
14:03:47 INFO - TEST-PASS | browser/components/urlbar/tests/legacy/browser_tabMatchesInAwesomebar.js | http://example.com/browser/browser/components/urlbar/tests/legacy/dummy_page.html#tabmatch16 was found in autocomplete, was expected -
14:03:47 INFO - Buffered messages finished
14:03:47 INFO - TEST-UNEXPECTED-FAIL | browser/components/urlbar/tests/legacy/browser_tabMatchesInAwesomebar.js | A promise chain failed to handle a rejection: this._remotenessChangingBrowsers.get(...) is undefined - stack: _asyncNavigateAndRestore@resource:///modules/sessionstore/SessionStore.jsm:3197:7
14:03:47 INFO - async*navigateAndRestore@resource:///modules/sessionstore/SessionStore.jsm:3147:19
14:03:47 INFO - navigateAndRestore@resource:///modules/sessionstore/SessionStore.jsm:371:12
14:03:47 INFO - LoadInOtherProcess@chrome://browser/content/browser.js:1139:3
14:03:47 INFO - _loadURI@chrome://browser/content/browser.js:1106:7
14:03:47 INFO - loadURI@resource://testing-common/BrowserTestUtils.jsm:638:5
14:03:47 INFO - async*step_6@chrome://mochitests/content/browser/browser/components/urlbar/tests/legacy/browser_tabMatchesInAwesomebar.js:87:3
14:03:47 INFO - Async*Tester_execTest/<@chrome://mochikit/content/browser-test.js:1108:34
14:03:47 INFO - async*Tester_execTest@chrome://mochikit/content/browser-test.js:1099:16
14:03:47 INFO - nextTest/<@chrome://mochikit/content/browser-test.js:997:9
14:03:47 INFO - SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<@chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:803:59
14:03:47 INFO - Rejection date: Fri Jan 25 2019 14:03:47 GMT+0000 (Greenwich Mean Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 257
14:03:47 INFO - Stack trace:
14:03:47 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:257
14:03:47 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1133
14:03:47 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest:1099
14:03:47 INFO - chrome://mochikit/content/browser-test.js:nextTest/<:997
14:03:47 INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:803
14:03:47 INFO - Leaving test bound step_6
14:03:47 INFO - Entering test bound step_7
14:03:47 INFO - Running step 7 - close all tabs

Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)

The stack here is session store, it looks like the code that is throwing here was changed just before this showed up by bug 1467223.

Nika, any idea what's happening here?

Blocks: 1467223
Component: Address Bar → Session Restore
Flags: needinfo?(nika)
Comment hidden (Intermittent Failures Robot)
Summary: Intermittent browser/components/urlbar/tests/legacy/browser_tabMatchesInAwesomebar.js | A promise chain failed to handle a rejection: this._remotenessChangingBrowsers.get(...) is undefined - stack: _asyncNavigateAndRestore@resource → Intermittent browser/components/urlbar/tests/browser/browser_tabMatchesInAwesomebar.js | A promise chain failed to handle a rejection: this._remotenessChangingBrowsers.get(...) is undefined - stack: _asyncNavigateAndRestore@resource
Attachment #9043057 - Attachment description: Bug 1522839 - Pass in initialBrowser explicitly, → Bug 1522839 - Cache permanentKey in case it changes during navigateAndRestore,

Comment 6

a month ago
Pushed by nlayzell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e960a090b466
Cache permanentKey in case it changes during navigateAndRestore, r=qdot

Comment 7

a month ago
bugherder
Status: NEW → RESOLVED
Last Resolved: a month ago
status-firefox67: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Flags: needinfo?(nika)

Thanks Nika

Assignee: nobody → nika

Looks like this failure affects Beta also. Is this something we can safely backport to take care of it there too?

status-firefox66: --- → affected
Flags: needinfo?(nika)
(Assignee)

Comment 10

a month ago

This patch should be backportable.

Flags: needinfo?(nika)
(Assignee)

Comment 11

a month ago

Comment on attachment 9043057 [details]
Bug 1522839 - Cache permanentKey in case it changes during navigateAndRestore,

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

None

User impact if declined

Potential blank documents when performing certain loads

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

None

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

Makes a minor change which is pretty simple all-around

String changes made/needed

none

Attachment #9043057 - Flags: approval-mozilla-beta?

Comment on attachment 9043057 [details]
Bug 1522839 - Cache permanentKey in case it changes during navigateAndRestore,

Fix for intermittent test failures, verified in nightly, let's uplift for beta 8.

Attachment #9043057 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: RESOLVED → VERIFIED

Comment 13

a month ago
bugherderuplift
status-firefox66: affected → fixed
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.