Closed Bug 1522941 Opened 5 years ago Closed 5 years ago

toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloaded_staged.js | Test timed out -

Categories

(Toolkit :: Application Update, defect, P5)

Unspecified
macOS
defect

Tracking

()

RESOLVED DUPLICATE of bug 1526865

People

(Reporter: intermittent-bug-filer, Unassigned)

Details

Attachments

(2 obsolete files)

#[markdown(off)]
Filed by: ccoroiu [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=224058202&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/M5lbIwqoSoqnh8HW7wyeug/runs/0/artifacts/public/logs/live_backing.log

09:21:09 INFO - 09:20:24:118 | TEST-INFO | chrome://mochitests/content/browser/toolkit/mozapps/update/tests/browser/shared.js | [setUpdateURL : 184] setting app.update.url to http://example.com/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?invalidCompleteSize=1&promptWaitTime=0&appVersion=66.0a1
09:21:09 INFO - Console message: AUS:SVC UpdateManager:_writeUpdatesToXMLFile - no updates to write. removing file: /Users/cltbld/Library/Caches/Mozilla/updates/Users/cltbld/tasks/task_1548435949/build/application/Firefox Nightly/active-update.xml
09:21:09 INFO - Console message: AUS:SVC UpdateManager:_writeUpdatesToXMLFile - no updates to write. removing file: /Users/cltbld/Library/Caches/Mozilla/updates/Users/cltbld/tasks/task_1548435949/build/application/Firefox Nightly/updates.xml
09:21:09 INFO - Console message: AUS:SVC getCanApplyUpdates - bypass the write since elevation can be used on Mac OS X
09:21:09 INFO - Console message: AUS:SVC readStringFromFile - file doesn't exist: /Users/cltbld/Library/Caches/Mozilla/updates/Users/cltbld/tasks/task_1548435949/build/application/Firefox Nightly/updates/0/update.status
09:21:09 INFO - Console message: AUS:SVC readStatusFile - status: null, path: /Users/cltbld/Library/Caches/Mozilla/updates/Users/cltbld/tasks/task_1548435949/build/application/Firefox Nightly/updates/0/update.status
09:21:09 INFO - Console message: AUS:SVC Checker:getUpdateURL - update URL: http://example.com/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?invalidCompleteSize=1&promptWaitTime=0&appVersion=66.0a1
09:21:09 INFO - Console message: AUS:SVC UpdateService.canCheckForUpdates - able to check for updates
09:21:09 INFO - Console message: AUS:SVC Checker: checkForUpdates, force: false
09:21:09 INFO - Console message: AUS:SVC UpdateService.canCheckForUpdates - able to check for updates
09:21:09 INFO - Console message: AUS:SVC Checker:getUpdateURL - update URL: http://example.com/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?invalidCompleteSize=1&promptWaitTime=0&appVersion=66.0a1
09:21:09 INFO - Console message: AUS:SVC Checker:checkForUpdates - sending request to: http://example.com/browser/toolkit/mozapps/update/tests/browser/app_update.sjs?invalidCompleteSize=1&promptWaitTime=0&appVersion=66.0a1
09:21:09 INFO - Console message: AUS:SVC Checker:onLoad - request completed downloading document
09:21:09 INFO - Console message: AUS:SVC Checker:onLoad - Getting sslStatus failed.
09:21:09 INFO - Console message: AUS:SVC Checker:onLoad - number of updates available: 1
09:21:09 INFO - Console message: AUS:SVC getElevationRequired - recursively testing write access on /Users/cltbld/tasks/task_1548435949/build/application/Firefox Nightly.app
09:21:09 INFO - Console message: AUS:SVC getElevationRequired - able to write to application bundle, elevation not required
09:21:09 INFO - Console message: AUS:SVC getCanApplyUpdates - bypass the write since elevation can be used on Mac OS X
09:21:09 INFO - Console message: AUS:SVC UpdateService:_selectAndInstallUpdate - download the update
09:21:09 INFO - Console message: AUS:SVC Creating Downloader
09:21:09 INFO - Console message: AUS:SVC UpdateService:_downloadUpdate
09:21:09 INFO - Console message: AUS:SVC readStringFromFile - file doesn't exist: /Users/cltbld/Library/Caches/Mozilla/updates/Users/cltbld/tasks/task_1548435949/build/application/Firefox Nightly/updates/0/update.status
09:21:09 INFO - Console message: AUS:SVC readStatusFile - status: null, path: /Users/cltbld/Library/Caches/Mozilla/updates/Users/cltbld/tasks/task_1548435949/build/application/Firefox Nightly/updates/0/update.status
09:21:09 INFO - Console message: AUS:SVC Downloader:downloadUpdate - url: http://example.com/browser/toolkit/mozapps/update/tests/browser/simple.mar, path: /Users/cltbld/Library/Caches/Mozilla/updates/Users/cltbld/tasks/task_1548435949/build/application/Firefox Nightly/updates/0/update.mar, interval: 0
09:21:09 INFO - Console message: AUS:SVC Downloader:onStartRequest - original URI spec: http://example.com/browser/toolkit/mozapps/update/tests/browser/simple.mar, final URI spec: http://example.com/browser/toolkit/mozapps/update/tests/browser/simple.mar
09:21:09 INFO - Console message: AUS:SVC Downloader:onProgress - progress: 1404/1404
09:21:09 INFO - Console message: AUS:SVC Downloader:onProgress - progress: 1404/1404
09:21:09 INFO - Console message: AUS:SVC Downloader:onStopRequest - original URI spec: http://example.com/browser/toolkit/mozapps/update/tests/browser/simple.mar, final URI spec: http://example.com/browser/toolkit/mozapps/update/tests/browser/simple.mar, status: 0
09:21:09 INFO - Console message: AUS:SVC Downloader:onStopRequest - status: 0, current fail: 0, max fail: 10, retryTimeout: 2000
09:21:09 INFO - Console message: AUS:SVC Downloader:_verifyDownload called
09:21:09 INFO - Console message: AUS:SVC Downloader:_verifyDownload downloaded size == expected size.
09:21:09 INFO - Console message: AUS:SVC shouldUseService - returning false
09:21:09 INFO - Console message: AUS:SVC getElevationRequired - recursively testing write access on /Users/cltbld/tasks/task_1548435949/build/application/Firefox Nightly.app
09:21:09 INFO - Console message: AUS:SVC getElevationRequired - able to write to application bundle, elevation not required
09:21:09 INFO - Console message: AUS:SVC Downloader:onStopRequest - setting state to: pending
09:21:09 INFO - Console message: AUS:SVC Downloader:onStopRequest - attempting to stage update: App Update Test
09:21:09 INFO - Buffered messages finished
09:21:09 INFO - TEST-UNEXPECTED-FAIL | toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloaded_staged.js | Test timed out -
09:21:09 INFO - GECKO(2404) | MEMORY STAT | vsize 4516MB | residentFast 461MB | heapAllocated 88MB

OS: Unspecified → macOS
Attached patch patch rev1 (obsolete) — Splinter Review
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Comment on attachment 9039456 [details] [diff] [review]
patch rev1

This didn't help :(
Attachment #9039456 - Attachment is obsolete: true
Comment on attachment 9039466 [details] [diff] [review]
patch

I've been seeing this failure around 1 out of every 20 to 40 OS X opt TV test runs. There is one in my previous try push in this bug as well. With this patch there were no failures out of 100 TV OS X opt test runs so I think it is good to go.

Note: two of the other new tests had failures and I'll fix those in their respective bugs.
Attachment #9039466 - Flags: review?(mhowell)

BTW: it is really nice to be able to make minor changes to the tests to have try perform verify runs on just the modified tests in all of the different modes it runs in. It makes it much easier to reproduce, etc.

Attachment #9039466 - Flags: review?(mhowell) → review+

I just realized that this patch won't help with browser_doorhanger_bc_downloaded_staged.js since that test hasn't been converted to use the continue file so I filed bug 1523430 and attached this patch (carried forward the r+) there since it will help with other failures.

Not certain when I can look at this further

Assignee: robert.strong.bugs → nobody
Status: ASSIGNED → NEW
Attachment #9039466 - Attachment is obsolete: true

There were definitely timeouts on Mac OS X and bug 1526865 should have resolved this bug. Renaming this bug to prevent it from being reopened since the code has changed significantly since this bug was filed.

Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Summary: Intermittent toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloaded_staged.js | Test timed out - → toolkit/mozapps/update/tests/browser/browser_doorhanger_bc_downloaded_staged.js | Test timed out -
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: