%20 replaced by spaces when copying out of location bar - issue persists

RESOLVED INCOMPLETE
(NeedInfo from)

Status

()

RESOLVED INCOMPLETE
2 months ago
13 days ago

People

(Reporter: andy, Unassigned, NeedInfo)

Tracking

64 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 months ago

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

I reported over a month ago that the issue described in Bug 1374850 (marked as " RESOLVED INVALID") persists (I'm now using FF 64.0.2 (64-bit) under Windows 10 and its the same). I cannot reopen that, and I don't know that anyone else will see my comment, so reporting here. See also Bug 475896

Example below. If you prefer to avoid PDFs, the problem also occurs with:

http://www.yellowad.co.uk/article.cfm?id=117920&headline=Beauty%20students%20at%20Barking%20and%20Dagenham%20College%20raise%20%C2%A3263%20for%20Macmillan&sectionIs=news&searchyear=2016

Actual results:

1 Visit http://uta-eickworth.de/Wilke%20Tierillustration%20Heft%20Web.pdf
2 copy address from location bar
3 pastes as: http://uta-eickworth.de/Wilke Tierillustration Heft Web.pdf

Expected results:

Should paste as http://uta-eickworth.de/Wilke%20Tierillustration%20Heft%20Web.pdf

That works for me as expected with Firefox64.0.2 on windows10.
I copied both URLs from the URL bar and pasted them in notepad and both URLS had the correctly escaped spaces.

Can you reproduce the problem in the Firefox safemode ?

Flags: needinfo?(andy)
(Reporter)

Comment 2

2 months ago

The problem occurs in exactly the same manner in safe mode.

Flags: needinfo?(andy)

Comment 3

2 months ago

Please also try a brand new profile. If it works there, one of the browser.urlbar.* about:config preferences might be to blame.
https://support.mozilla.com/kb/profile-manager-create-and-remove-firefox-profiles

Component: Untriaged → Address Bar

I also cannot reproduce if I copy from the urlbar and paste in another app, like a text editor.
check you didn't set browser.urlbar.decodeURLsOnCopy to true.

Flags: needinfo?(andy)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 days ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.