Copying a message filter won't copy when the filter is applied

RESOLVED FIXED in Thunderbird 67.0

Status

defect
RESOLVED FIXED
4 months ago
3 months ago

People

(Reporter: orctarorga, Assigned: aceman)

Tracking

Thunderbird 67.0

Thunderbird Tracking Flags

(thunderbird_esr6065+ fixed, thunderbird66 fixed, thunderbird67 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 months ago

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:64.0) Gecko/20100101 Firefox/64.0

Steps to reproduce:

From the toolbar, click AppMenu(the button with three horizontal bars) -> Message Filters -> Message Filters, to open the Message Filters window.
Create a filter with arbitrary triggering condition and actions, but change the settings on when the filter is applied. In default, Manually Run and Getting New Mail are selected. For example, we can turn on Manually Run on but all others off.
Then copy the filter we just created, and edit the configuration for the new duplicated one.

Actual results:

It turns out both triggering conditions and actions are correctly copied, but the fields on when it's applied would be left on default values.

Expected results:

All settings of an existing filter shall be correctly copied.

(Assignee)

Comment 1

4 months ago

Yes, it seems the events triggering the filter are omitted from the copy when this was implemented in bug 214548.

Blocks: 214548
Status: UNCONFIRMED → NEW
Component: Filters → Filters
Ever confirmed: true
OS: Unspecified → All
Product: Thunderbird → MailNews Core
Hardware: Unspecified → All
(Assignee)

Comment 2

4 months ago
Posted patch 1523048.patchSplinter Review
Assignee: nobody → acelists
Status: NEW → ASSIGNED
Attachment #9040998 - Flags: review?(jorgk)

Comment 3

4 months ago
Comment on attachment 9040998 [details] [diff] [review]
1523048.patch

Thanks. The net change is a one liner here.
Attachment #9040998 - Flags: review?(jorgk) → review+

Updated

4 months ago
Keywords: checkin-needed

Comment 4

4 months ago

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/70d44ca12af8
when copying a filter, copy its triggering events too (filterType). r=jorgk

Status: ASSIGNED → RESOLVED
Last Resolved: 4 months ago
Keywords: checkin-needed
Resolution: --- → FIXED

Updated

4 months ago
Target Milestone: --- → Thunderbird 67.0

Updated

4 months ago
Attachment #9040998 - Flags: approval-comm-esr60+
Attachment #9040998 - Flags: approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.