Closed Bug 1523060 Opened 3 years ago Closed 3 years ago

No way to cancel editing a string

Categories

(Toolkit :: Preferences, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1522659
Tracking Status
firefox66 --- affected

People

(Reporter: yoasif, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: nightly-community)

STR:

  1. Open new about:config
  2. Click Edit near a string value
  3. Press escape

What happens:

Nothing. There doesn't appear to be a way to back out of a change to a string. This is especially troublesome if you edit the value but realize that you made a mistake and want to go back to the persisted value.

Expected result:

  • Cancel button should appear near Save button
  • escape key should back out of the change
Blocks: 1493439

See bug 1522659 comment 3, we won't have a Cancel button but we're considering accepting or writing a patch with regression tests for canceling with the Escape key.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1522659
Duplicate of this bug: 1541262
You need to log in before you can comment on or make changes to this bug.