Closed Bug 1523098 Opened 6 years ago Closed 5 years ago

Intermittent mochitest [taskcluster:error] Task aborted - max run time exceeded

Categories

(Testing :: Mochitest, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1589796

People

(Reporter: intermittent-bug-filer, Assigned: gbrown)

References

Details

(Keywords: intermittent-failure, Whiteboard: [stockwell infra])

#[markdown(off)]
Filed by: rmaries [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=224220676&repo=try

https://queue.taskcluster.net/v1/task/UWwd5XS8RSimmxlnqKHm8w/runs/0/artifacts/public/logs/live_backing.log

14:32:55 INFO - TEST-START | devtools/client/webconsole/test/mochitest/browser_webconsole_keyboard_accessibility.js
14:33:07 INFO - GECKO(1356) | Handler function executor threw an exception: Error: Must use a native JavaScript stack frame
14:33:07 INFO - GECKO(1356) | Stack: callFunctionWithAsyncStack@resource://devtools/shared/platform/stack.js:61:10
14:33:07 INFO - GECKO(1356) | executor@resource://devtools/shared/DevToolsUtils.js:59:9
14:33:07 INFO - GECKO(1356) | exports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14
14:33:07 INFO - GECKO(1356) | Line: 61, column: 10
14:33:07 INFO - GECKO(1356) | console.error: "Handler function executor threw an exception: Error: Must use a native JavaScript stack frame\nStack: callFunctionWithAsyncStack@resource://devtools/shared/platform/stack.js:61:10\nexecutor@resource://devtools/shared/DevToolsUtils.js:59:9\nexports.makeInfallible/<@resource://devtools/shared/ThreadSafeDevToolsUtils.js:109:14\nLine: 61, column: 10"
14:39:45 INFO - JavaScript error: jar:file:///Z:/task_1548511509/build/application/firefox/omni.ja!/components/nsPlacesExpiration.js, line 762: TypeError: this._db is undefined
14:48:45 INFO - JavaScript error: jar:file:///Z:/task_1548511509/build/application/firefox/omni.ja!/components/nsPlacesExpiration.js, line 762: TypeError: this._db is undefined
14:57:45 INFO - JavaScript error: jar:file:///Z:/task_1548511509/build/application/firefox/omni.ja!/components/nsPlacesExpiration.js, line 762: TypeError: this._db is undefined
15:06:45 INFO - JavaScript error: jar:file:///Z:/task_1548511509/build/application/firefox/omni.ja!/components/nsPlacesExpiration.js, line 762: TypeError: this._db is undefined
15:15:45 INFO - JavaScript error: jar:file:///Z:/task_1548511509/build/application/firefox/omni.ja!/components/nsPlacesExpiration.js, line 762: TypeError: this._db is undefined
15:24:45 INFO - JavaScript error: jar:file:///Z:/task_1548511509/build/application/firefox/omni.ja!/components/nsPlacesExpiration.js, line 762: TypeError: this._db is undefined
15:33:45 INFO - JavaScript error: jar:file:///Z:/task_1548511509/build/application/firefox/omni.ja!/components/nsPlacesExpiration.js, line 762: TypeError: this._db is undefined
15:42:45 INFO - JavaScript error: jar:file:///Z:/task_1548511509/build/application/firefox/omni.ja!/components/nsPlacesExpiration.js, line 762: TypeError: this._db is undefined
[taskcluster:error] Aborting task...
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 196 (child process of PID 1356) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 4232 (child process of PID 1356) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 4168 (child process of PID 1356) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 4928 (child process of PID 1356) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 4264 (child process of PID 1356) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 4400 (child process of PID 1356) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 2312 (child process of PID 1356) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 5908 (child process of PID 1356) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 3132 (child process of PID 1356) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 1772 (child process of PID 5064) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 5176 (child process of PID 5064) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 5560 (child process of PID 5064) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 1356 (child process of PID 5064) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 4652 (child process of PID 2532) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 5064 (child process of PID 2532) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 2532 (child process of PID 3192) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z] SUCCESS: The process with PID 3192 (child process of PID 4604) has been terminated.
[taskcluster 2019-01-26T15:43:54.718Z]
[taskcluster 2019-01-26T15:43:54.719Z] === Task Finished ===
[taskcluster 2019-01-26T15:43:54.719Z] Task Duration: 1h29m32.3787528s
[taskcluster 2019-01-26T15:43:55.389Z] Uploading artifact public/logs/localconfig.json from file logs\localconfig.json with content encoding "gzip", mime type "application/octet-stream" and expiry 2019-02-09T12:11:10.130Z
[taskcluster 2019-01-26T15:43:56.491Z] Uploading artifact public/logs/log_critical.log from file logs\log_critical.log with content encoding "gzip", mime type "text/plain" and expiry 2019-02-09T12:11:10.130Z
[taskcluster 2019-01-26T15:43:57.003Z] Uploading artifact public/logs/log_error.log from file logs\log_error.log with content encoding "gzip", mime type "text/plain" and expiry 2019-02-09T12:11:10.130Z
[taskcluster 2019-01-26T15:43:57.515Z] Uploading artifact public/logs/log_fatal.log from file logs\log_fatal.log with content encoding "gzip", mime type "text/plain" and expiry 2019-02-09T12:11:10.130Z
[taskcluster 2019-01-26T15:43:58.041Z] Uploading artifact public/logs/log_info.log from file logs\log_info.log with content encoding "gzip", mime type "text/plain" and expiry 2019-02-09T12:11:10.130Z
[taskcluster 2019-01-26T15:43:58.918Z] Uploading artifact public/logs/log_raw.log from file logs\log_raw.log with content encoding "gzip", mime type "text/plain" and expiry 2019-02-09T12:11:10.130Z
[taskcluster 2019-01-26T15:43:59.450Z] Uploading artifact public/logs/log_warning.log from file logs\log_warning.log with content encoding "gzip", mime type "text/plain" and expiry 2019-02-09T12:11:10.130Z
[taskcluster 2019-01-26T15:44:00.003Z] Uploading artifact public/test_info/manifests.list from file build\blobber_upload_dir\manifests.list with content encoding "gzip", mime type "application/octet-stream" and expiry 2019-02-09T12:11:10.130Z
[taskcluster 2019-01-26T15:44:00.558Z] Uploading artifact public/test_info/mochitest-devtools-chrome-chunked_errorsummary.log from file build\blobber_upload_dir\mochitest-devtools-chrome-chunked_errorsummary.log with content encoding "gzip", mime type "text/plain" and expiry 2019-02-09T12:11:10.130Z
[taskcluster 2019-01-26T15:44:01.119Z] Uploading artifact public/test_info/mochitest-devtools-chrome-chunked_raw.log from file build\blobber_upload_dir\mochitest-devtools-chrome-chunked_raw.log with content encoding "gzip", mime type "text/plain" and expiry 2019-02-09T12:11:10.130Z
[taskcluster 2019-01-26T15:44:01.655Z] Uploading artifact public/test_info/system-info.log from file build\blobber_upload_dir\system-info.log with content encoding "gzip", mime type "text/plain" and expiry 2019-02-09T12:11:10.130Z
[taskcluster 2019-01-26T15:44:02.430Z] Uploading redirect artifact public/logs/live.log to URL https://queue.taskcluster.net/v1/task/UWwd5XS8RSimmxlnqKHm8w/runs/0/artifacts/public/logs/live_backing.log with mime type "text/plain; charset=utf-8" and expiry 2019-02-09T12:11:10.130Z
[taskcluster:error] Task aborted - max run time exceeded

debug-mochitest-devtools-chrome-e10s-16 jobs are permafailling on m-c with this failure since this push:
https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=4f4de7a970353de0c86ee8cf7470ea00feb0cec9

Flags: needinfo?(nchevobbe)

(In reply to Alexandru Michis [:malexandru] from comment #26)

debug-mochitest-devtools-chrome-e10s-16 jobs are permafailling on m-c with this failure since this push:
https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=4f4de7a970353de0c86ee8cf7470ea00feb0cec9

Treeherder link: https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&resultStatus=testfailed%2Cbusted%2Cexception&tochange=adc59d50adf815ad6764ff235f833a5ba74291b6&fromchange=5f0f3775605323d865539da3a7c4cb3d1fd36ff2&searchStr=debug-mochitest-devtools-chrome-e10s-16&selectedJob=254139999

Push log: https://hg.mozilla.org/mozilla-central/pushloghtml?changeset=b8938b6afa9c4b498ec016d1b3d50be0e50684c0

This is perma-failing on tier2 starting with the above. Looked in the most recent 10 logs and most failures are in devtools/client/webconsole/test/mochitest/browser_webconsole_<something>

Boris could bug 1562257 have had any influence here?

Flags: needinfo?(bzbarsky)

Boris could bug 1562257 have had any influence here?

In theory, sure, in that it could have affected the perfomance characteristics of something. But in practice, I expect that's highly unlikely.

If we are in fact seeing perma-fails, seems like just bisecting this on try to figure out the changeset that is responsible would be the way to go...

Flags: needinfo?(bzbarsky) → needinfo?(apavel)

I looked into this, and I find that there are assertions for tests and it adds 20 seconds/test which when we 29 of them in this log:
https://taskcluster-artifacts.net/dyMfh2aqSma23hE1uMvM8g/0/public/logs/live_backing.log

that adds 10 minutes to the job, which might be the problem.

Here is the assertion:
[task 2019-08-01T04:09:21.421Z] 04:09:21 INFO - GECKO(10112) | [Parent 8000, Main Thread] ###!!! ASSERTION: Unexpected UpdateTransformLayer hint: '!(aChange & nsChangeHint_UpdateTransformLayer) || aFrame->IsTransformed() || aFrame->StyleDisplay()->HasTransformStyle()', file z:/build/build/src/layout/base/RestyleManager.cpp, line 1205
[task 2019-08-01T04:09:21.421Z] 04:09:21 INFO - GECKO(10112) | #01: mozilla::PresShell::DoFlushPendingNotifications(mozilla::ChangesToFlush) [layout/base/PresShell.cpp:4191]
[task 2019-08-01T04:09:21.421Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.421Z] 04:09:21 INFO - GECKO(10112) | #02: mozilla::dom::Document::FlushPendingNotifications(mozilla::ChangesToFlush) [dom/base/Document.cpp:10043]
[task 2019-08-01T04:09:21.421Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.421Z] 04:09:21 INFO - GECKO(10112) | #03: nsIContent::GetPrimaryFrame(mozilla::FlushType) [dom/base/Element.cpp:229]
[task 2019-08-01T04:09:21.421Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.422Z] 04:09:21 INFO - GECKO(10112) | #04: mozilla::dom::Element::GetBoundingClientRect() [dom/base/Element.cpp:1010]
[task 2019-08-01T04:09:21.422Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.422Z] 04:09:21 INFO - GECKO(10112) | #05: static bool mozilla::dom::Element_Binding::getBoundingClientRect(struct JSContext *, class JS::Handle<JSObject *>, class mozilla::dom::Element *, const class JSJitMethodCallArgs & const) [s3:gecko-generated-sources:f2743d2830e993e23ab5946aac392732d16059714da7516673705bc2c20ba0a145d3c9d905b4ec8005b583e812fa7969fc9878cb4dc8fb9621fa0cd4fa402ff9/dom/bindings/ElementBinding.cpp::3015]
[task 2019-08-01T04:09:21.422Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.422Z] 04:09:21 INFO - GECKO(10112) | #06: mozilla::dom::binding_detail::GenericMethod<mozilla::dom::binding_detail::NormalThisPolicy,mozilla::dom::binding_detail::ThrowExceptions>(JSContext *,unsigned int,JS::Value *) [dom/bindings/BindingUtils.cpp:3181]
[task 2019-08-01T04:09:21.422Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.422Z] 04:09:21 INFO - GECKO(10112) | #07: CallJSNative(JSContext ,bool ()(JSContext *,unsigned int,JS::Value *),JS::CallArgs const &) [js/src/vm/Interpreter.cpp:448]
[task 2019-08-01T04:09:21.422Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.422Z] 04:09:21 INFO - GECKO(10112) | #08: js::InternalCallOrConstruct(JSContext *,JS::CallArgs const &,js::MaybeConstruct) [js/src/vm/Interpreter.cpp:540]
[task 2019-08-01T04:09:21.422Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.422Z] 04:09:21 INFO - GECKO(10112) | #09: static bool InternalCall(struct JSContext *, const class js::AnyInvokeArgs & const) [js/src/vm/Interpreter.cpp:595]
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO - GECKO(10112) | #10: static bool Interpret(struct JSContext *, class js::RunState & const) [js/src/vm/Interpreter.cpp:3084]
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO - GECKO(10112) | #11: js::RunScript(JSContext *,js::RunState &) [js/src/vm/Interpreter.cpp:425]
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO - GECKO(10112) | #12: js::InternalCallOrConstruct(JSContext *,JS::CallArgs const &,js::MaybeConstruct) [js/src/vm/Interpreter.cpp:568]
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO - GECKO(10112) | #13: static bool InternalCall(struct JSContext *, const class js::AnyInvokeArgs & const) [js/src/vm/Interpreter.cpp:595]
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO - GECKO(10112) | #14: js::Call(JSContext *,JS::Handle<JS::Value>,JS::Handle<JS::Value>,js::AnyInvokeArgs const &,JS::MutableHandle<JS::Value>) [js/src/vm/Interpreter.cpp:611]
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.423Z] 04:09:21 INFO - GECKO(10112) | #15: js::jit::InvokeFunction(JSContext *,JS::Handle<JSObject *>,bool,bool,unsigned int,JS::Value *,JS::MutableHandle<JS::Value>) [js/src/jit/VMFunctions.cpp:259]
[task 2019-08-01T04:09:21.424Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.424Z] 04:09:21 INFO - GECKO(10112) | #16: js::jit::InvokeFromInterpreterStub(JSContext *,js::jit::InterpreterStubExitFrameLayout *) [js/src/jit/VMFunctions.cpp:288]
[task 2019-08-01T04:09:21.424Z] 04:09:21 INFO -
[task 2019-08-01T04:09:21.424Z] 04:09:21 INFO - GECKO(10112) | #17: ??? (???:???)

here is a link to the assertion:
https://searchfox.org/mozilla-central/source/layout/base/RestyleManager.cpp#1202

:emilio, I see you authored the code for the assertion, could you help figure out why this is occurring for the devtools tests on win10 when in ccov (sloowww) mode and how to prevent it?

Flags: needinfo?(jmaher) → needinfo?(emilio)

I didn't really author that assertion (it comes from the old style system code), and it is a really really old assertion which is known to fail in some cases since very very long ago (bug 786876 is open since forever).

I can go dig the archeology to see why it's there or what not, but easiest path forward is probably changing it to NS_WARNING_ASSERTION, if it's blocking something.

Flags: needinfo?(emilio)

I will be doing a try push to test this!

Recent occurrences here are bug 1569835.

Joel, after bug 1569835 landed, the dt-wr is permafailing with another test, bug 1571251. Seems like covering one failure for the job uncovers others. Is there a more permanent solution to get this job green?

Flags: needinfo?(jmaher)

I think this has been perma timeout since the beginning, and it always seems to be tests taking a long time.

I did experiment with moving the assertion to a warning and while that saved some time on ~30 tests, it didn't end up getting this passing. I also tried changing the chunking, but we still get stuck with the _webconsole tests.

One option is to skip the webconsole tests on win10/ccov:
https://searchfox.org/mozilla-central/source/devtools/client/webconsole/test/mochitest/browser.ini#4

this isn't ideal as it disables 325 tests. Maybe we can split this into multiple ini files to have 4 or 5 webconsole manifests? :jlast, do you know why the webconsole tests have so many files? The problem is on windows10/ccov runs each test takes many seconds (typically 10+), so we timeout all the time.

Flags: needinfo?(jmaher) → needinfo?(jlaster)

I'm curious what nicolas thinks.

Flags: needinfo?(jlaster)
Whiteboard: [stockwell disable-recommended]
Depends on: 1576025

In the last 7 days there were 26 failures associated with this bug: https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-09-07&endday=2019-09-14&tree=trunk&bug=1523098
Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=266579893&repo=mozilla-central&lineNumber=15292
Occurs on android-hw-p2-8-0-arm7-api-16, macosx1014-64-shippable, windows10-64-ccov debug and opt build types.

Depends on: 1582241

There are 34 failures associated to this bug in the last 7 days. These are occurring on macosx1014-64-shippable and macosx1014-64, debug and opt builds.

Hi Geoff, can you advise on how to proceed here? There is no reply from the triage owner and this has reached the disable-recommended queue.

Flags: needinfo?(gbrown)

Oops sorry, let me check if there's anything I can do here

this isn't ideal as it disables 325 tests. Maybe we can split this into multiple ini files to have 4 or 5 webconsole manifests? :jlast, do you know why the webconsole tests have so many files? The problem is on windows10/ccov runs each test takes many seconds (typically 10+), so we timeout all the time.

The console has many files because we have a lot of tests. (See devtools/client/webconsole/test/browser/browser.ini )
I didn't know we can have multiple .ini files in a given folder. I'll check what could be done.

Flags: needinfo?(nchevobbe)

Thank you Nicolas, I'll remove the ni for Geoff since you're looking into it.

Flags: needinfo?(gbrown)

splitting browser.ini into 3 files: https://treeherder.mozilla.org/#/jobs?repo=try&revision=08e3cb78b37ec3b10d3290937526cc93bc74469d

what jobs/platforms should I retrigger to ensure it has a positive effect on this bug?

Debug:
windows10-64-ccov
test suite: mochitest-devtools-chrome-e10s-16
macosx1014-64
test suite: mochitest-browser-chrome-e10s-8, mochitest-browser-chrome-e10s-7, mochitest-browser-chrome-e10s-6, mochitest-browser-chrome-e10s-3

Opt:
macosx1014-64-shippable
test suite: mochitest-devtools-webreplay-e10s

Depends on: 1587201
Depends on: 1587207

There are 109 total failures in the last 7 days on android-hw-p2-8-0-arm7-api-16 all build types, macosx1014-64 debug, macosx1014-64-shippable opt and windows10-64-ccov debug.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=270737479&repo=mozilla-central&lineNumber=16209

[task 2019-10-10T20:01:55.450Z] 20:01:55 INFO - TEST-START | devtools/client/webconsole/test/browser/browser_webconsole_string.js
[task 2019-10-10T20:01:55.501Z] 20:01:55 INFO - GECKO(4408) | ++DOCSHELL 00000175AD32D800 == 2 [pid = 6208] [id = {f19deb7a-1070-4161-a46d-009f2f386e76}]
[task 2019-10-10T20:01:55.501Z] 20:01:55 INFO - GECKO(4408) | ++DOMWINDOW == 3 (00000175ACA023E0) [pid = 6208] [serial = 579] [outer = 0000000000000000]
[task 2019-10-10T20:01:55.501Z] 20:01:55 INFO - GECKO(4408) | ++DOMWINDOW == 4 (00000175AD312400) [pid = 6208] [serial = 580] [outer = 00000175ACA023E0]
[task 2019-10-10T20:01:55.709Z] 20:01:55 INFO - GECKO(4408) | ++DOMWINDOW == 5 (00000175B1CD4000) [pid = 6208] [serial = 581] [outer = 00000175ACA023E0]
[task 2019-10-10T20:01:56.095Z] 20:01:56 INFO - GECKO(4408) | ++DOCSHELL 0000023745D83800 == 9 [pid = 4332] [id = {e4a2bda7-3bac-49ca-9dc0-e29f0554b0c1}]
[task 2019-10-10T20:01:56.095Z] 20:01:56 INFO - GECKO(4408) | ++DOMWINDOW == 30 (000002374C728B60) [pid = 4332] [serial = 1928] [outer = 0000000000000000]
[task 2019-10-10T20:01:56.114Z] 20:01:56 INFO - GECKO(4408) | ++DOMWINDOW == 31 (000002374AF79400) [pid = 4332] [serial = 1929] [outer = 000002374C728B60]
[task 2019-10-10T20:01:56.404Z] 20:01:56 INFO - GECKO(4408) | ++DOMWINDOW == 32 (0000023749AF9000) [pid = 4332] [serial = 1930] [outer = 000002374C728B60]
[taskcluster:error] Aborting task...
[task 2019-10-10T20:01:59.888Z] 20:01:59 INFO - GECKO(4408) | ++DOMWINDOW == 33 (000002374DD90000) [pid = 4332] [serial = 1931] [outer = 000002374C728B60]
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 9720 (child process of PID 4332) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 1588 (child process of PID 4332) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 7792 (child process of PID 4332) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 4696 (child process of PID 4332) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 6208 (child process of PID 4332) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 1300 (child process of PID 4332) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 10588 (child process of PID 4332) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 10808 (child process of PID 4332) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 1340 (child process of PID 4332) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 4784 (child process of PID 4332) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 4332 (child process of PID 4408) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 10432 (child process of PID 7780) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 9644 (child process of PID 7780) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 1928 (child process of PID 7780) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 4408 (child process of PID 7780) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 3408 (child process of PID 6356) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 7780 (child process of PID 6356) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 6356 (child process of PID 10404) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 2348 (child process of PID 7628) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 10404 (child process of PID 7628) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z] SUCCESS: The process with PID 7628 (child process of PID 10756) has been terminated.
[taskcluster 2019-10-10T20:01:59.915Z]
[taskcluster 2019-10-10T20:01:59.916Z] === Task Finished ===
[taskcluster 2019-10-10T20:01:59.916Z] Task Duration: 2h0m1.5628239s
[taskcluster 2019-10-10T20:02:00.700Z] Uploading artifact public/logs/localconfig.json from file logs\localconfig.json with content encoding "gzip", mime type "application/octet-stream" and expiry 2020-10-09T16:27:56.077Z
[taskcluster 2019-10-10T20:02:01.749Z] Uploading artifact public/test_info/manifests.list from file build\blobber_upload_dir\manifests.list with content encoding "gzip", mime type "application/octet-stream" and expiry 2020-10-09T16:27:56.077Z
[taskcluster 2019-10-10T20:02:02.293Z] Uploading artifact public/test_info/mochitest-devtools-chrome-chunked_errorsummary.log from file build\blobber_upload_dir\mochitest-devtools-chrome-chunked_errorsummary.log with content encoding "gzip", mime type "text/plain" and expiry 2020-10-09T16:27:56.077Z
[taskcluster 2019-10-10T20:02:02.836Z] Uploading artifact public/test_info/mochitest-devtools-chrome-chunked_raw.log from file build\blobber_upload_dir\mochitest-devtools-chrome-chunked_raw.log with content encoding "gzip", mime type "text/plain" and expiry 2020-10-09T16:27:56.077Z
[taskcluster 2019-10-10T20:02:04.148Z] Uploading artifact public/test_info/system-info.log from file build\blobber_upload_dir\system-info.log with content encoding "gzip", mime type "text/plain" and expiry 2020-10-09T16:27:56.077Z
[taskcluster 2019-10-10T20:02:04.895Z] Uploading redirect artifact public/logs/live.log to URL https://queue.taskcluster.net/v1/task/QTRqZs_CQiaifPqqeTR_-g/runs/0/artifacts/public/logs/live_backing.log with mime type "text/plain; charset=utf-8" and expiry 2020-10-09T16:27:56.077Z
[taskcluster:error] Task aborted - max run time exceeded

Whiteboard: [stockwell disable-recommended] → [stockwell needswork:owner]

The Windows 10 x64 ccov debug dt16 chunk is effectively perma failing.

Depends on: 1588160
Depends on: 1588161
Assignee: nobody → gbrown
Component: Console → Mochitest
Product: DevTools → Testing
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: [stockwell disable-recommended] → [stockwell infra]
You need to log in before you can comment on or make changes to this bug.