XUL apps having third-party theme support adds blank lines to theme list

RESOLVED INVALID

Status

Core Graveyard
Skinability
RESOLVED INVALID
16 years ago
7 years ago

People

(Reporter: reidardj, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530
BuildID:    2002053012

I'm making a XUL app called the Home Button, and have added support for
third-party themes. For each theme that the app supports, but the user doesn't
have, this adds a blank line in the View > Apply Themes menu, and in Edit >
Preferences > Appearance > Themes.

Reproducible: Always
Steps to Reproduce:
1. Go to http://home.no.net/trihand/mozilla/home/en/
2. Install the Home Button with support for one or more themes that you don't have.

Actual Results:  One or more blank lines in View > Apply Theme.

Expected Results:  No blank lines.

From install.js in Home Button 0.4:

registerChrome(SKIN | DELAYED_CHROME, getFolder("Chrome", "home.jar"),
"skin/classic/");
registerChrome(SKIN | DELAYED_CHROME, getFolder("Chrome", "home.jar"),
"skin/modern/");
registerChrome(SKIN | DELAYED_CHROME, getFolder("Chrome", "home.jar"),
"skin/ieskin/");
registerChrome(SKIN | DELAYED_CHROME, getFolder("Chrome", "home.jar"),
"skin/eskimo/");
registerChrome(SKIN | DELAYED_CHROME, getFolder("Chrome", "home.jar"),
"skin/littlemozilla/");
registerChrome(SKIN | DELAYED_CHROME, getFolder("Chrome", "home.jar"),
"skin/wood/");
registerChrome(SKIN | DELAYED_CHROME, getFolder("Chrome", "home.jar"),
"skin/lofi/");
registerChrome(SKIN | DELAYED_CHROME, getFolder("Chrome", "home.jar"),
"skin/pinball/");
registerChrome(SKIN | DELAYED_CHROME, getFolder("Chrome", "home.jar"),
"skin/skypilot/");
registerChrome(SKIN | DELAYED_CHROME, getFolder("Chrome", "home.jar"),
"skin/lopburi/");
registerChrome(SKIN | DELAYED_CHROME, getFolder("Chrome", "home.jar"),
"skin/kzilla/");

From chome.rdf in Mozilla/chrome:

  <RDF:Seq about="urn:mozilla:skin:ieskin/1.0:packages">
    <RDF:li resource="urn:mozilla:skin:ieskin/1.0:home"/>
  </RDF:Seq>

If ieskin (or any other theme) is not installed, Mozilla should ignore the
section in chome.rdf. The fix should be easy: ignore themes without name
information.

Updated

16 years ago
Blocks: 153859
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

14 years ago
Duplicate of Bug 139285?
Assignee: bugs → skinability
QA Contact: pmac
Product: Core → Core Graveyard

Comment 2

7 years ago
XPFE RDF chrome registry does not exist any more.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.