Undefined xptcstubs on linux/MIPS + gcc3.1

RESOLVED WORKSFORME

Status

()

Core
XPCOM
--
major
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Daniel Laird, Assigned: dougt)

Tracking

Trunk
Other
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Philips 
Southampton; Q312461; .NET CLR 1.0.3705)
BuildID:    20020617

I am trying to build mozilla on a MIPS process or and it fails when trying to 
build regExport

Reproducible: Always
Steps to Reproduce:
1.Just build it
2.
3.

Actual Results:  c++  -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -
Wconversion -Wpointer-arith -Wbad-function-cast -Wcast-align -Woverloaded-
virtual -Wsynth -Wno-ctor-dtor-privacy -pedantic -Wno-long-long -Wa,-xgot -
fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O2 -o regExport 
regExport.o    -L../../../dist/bin -L../../../dist/lib -L../../../dist/bin -
lxpcom -L/local/mozilla/dist/lib -lplds4 -lplc4 -lnspr4 -lpthread -ldl -lc   -
ldl -lm  -lc
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub203
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub156
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub184
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub128
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub226
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub246
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub112
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub180
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub230
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub147
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub151
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub116
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub111
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub231
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub141
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub104
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub58()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub53()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub82()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub93()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub212
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub145
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub108
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub175
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub235
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub205
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub209
()'
../../../dist/bin/libxpcom.so: undefined reference to `nsXPTCStubBase::Stub240()
........

Expected Results:  built it i hope
Here's a silly question: What's a MIPS core?  

What OS are you using and which source tree?
(Reporter)

Comment 2

16 years ago
A MIPS core is a MIPS processor ie pr3940 (--host=mipsel-unknown-linux-gnu)  
The OS is Linux 2.4.14 I am using gcc-3.1 compiler chain.  I have built with 
the options suggested in the build a distribution web page.  I believe the 
Error to be somethin to do with having no extern C stuff in the cpp files for 
this library.  The alpha build appears to have had a similar problem but i can 
not understand the patch.
Actually, that looks like a port-specific xptcall file didn't get linked into
libxpcom.  Can you attach a full build log and config/autoconf.mk .
Assignee: seawood → dougt
Component: Build Config → XPCOM
QA Contact: granrose → scc
Summary: Will not build regExport on a MIPS core. Undefined stubs → Undefined xptcstubs on linux/MIPS + gcc3.1

Comment 4

16 years ago
BZ 71627 is the same thing I think... is the mips/irix patch here useful to you?

Comment 5

15 years ago
Daniel, are you still experiencing this problem?

Comment 6

15 years ago
No answer from reporter since over 1 month, close this as WFM.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.