Closed Bug 1523419 Opened 2 years ago Closed 1 year ago

Editing of Chat Room Topic through UI not working

Categories

(Thunderbird :: Instant Messaging, defect)

Unspecified
All
defect
Not set
normal

Tracking

(thunderbird68+ fixed, thunderbird69 fixed)

RESOLVED FIXED
Thunderbird 69.0
Tracking Status
thunderbird68 + fixed
thunderbird69 --- fixed

People

(Reporter: khushil324, Assigned: khushil324)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Step to reproduce :

  1. Log into IRC server.
  2. Open any chatroom ex. testing-chat
  3. Click on the topic of the chat room on the top right.

Expected Behaviour :

Textbox will be focused and you will be able to edit/write the topic.

Actual Behaviour :

Textbox border is shown but Textbox is not focused and you are not able to edit the topic.

Note :

On other services like Google chat and Twitter, it should be read-only textbox but when you click currently, it is showing a textbox border and text cursor on hover. You will not be able to edit the topic.

You will be able to edit the topic through command /topic in the chat.

This is happening in at least beta. I hope this isn't an issue in ESR!

Version: Trunk → 65

jorgk checked ESR and did not have any issue changing the topic.

Keywords: regression

Clicking around I get

TypeError: controller is null[Learn More] textbox.js:157:13
_doPopupItemEnabling chrome://global/content/elements/textbox.js:157
onxblcontextmenu chrome://global/content/bindings/textbox.xml:260

... and looking at our fork of textbox.xml https://hg.mozilla.org/comm-central/log/tip/common/bindings/textbox.xml I'd suspect bug 1466389.

In textbox binding, "editor" property is showing/returning null. What can be done here?

Blocks: 1521610

khushil, I see that bug 1521610 landed, does that fix this or is there more work to do?

Flags: needinfo?(khushil324)

(In reply to Patrick Cloke [:clokep] from comment #5)

khushil, I see that bug 1521610 landed, does that fix this or is there more work to do?

No, this bug is still there to work on. I tried it but did not find anything meaningful.

Flags: needinfo?(khushil324)

We need to fix that for TB 68.

Assignee: nobody → khushil324

Somehow, this binding got removed without addressing the topic editing functionality: https://dxr.mozilla.org/comm-esr60/source/mail/components/im/content/chat.css#81 in TB 68.
Both the issues, this and Bug 1559641 are because of this removal. I will submit the patch for Bug 1559641 after receiving the feedback from this patch.

Attachment #9072528 - Flags: ui-review?(jorgk)
Attachment #9072528 - Flags: review?(mkmelin+mozilla)
Attachment #9072528 - Flags: review?(clokep)
Status: NEW → ASSIGNED

If you want to check this on M-C tip, note bug 1559523 comment #2 and back out M-C rev 72e19189bb99e159b2974cbcda69647211962df3 locally.

Comment on attachment 9072528 [details] [diff] [review]
Bug-1523419_chat-room-edit-topic.patch

This works, at least on IRC where I tried it. According to comment #0, Google and Twitter (the latter currently not working) should offer a read-only box.

We generally use feedback for getting someone to try something and confirm it working. ui-review is for changes to the UI which hasn't changed here, only to the point that non-working was turned back to working :-)
Attachment #9072528 - Flags: ui-review?(jorgk) → feedback+
Summary: the malfunctioning in editing of Chat Room Topic through UI → Editing of Chat Room Topic through UI not working
Comment on attachment 9072528 [details] [diff] [review]
Bug-1523419_chat-room-edit-topic.patch

Review of attachment 9072528 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. I would prefer to use better variable names. topic instead of elt, and topicInput instead of eltInput
Attachment #9072528 - Flags: review?(mkmelin+mozilla) → review+

(In reply to Magnus Melin [:mkmelin] from comment #11)

Looks good. I would prefer to use better variable names. topic instead of
elt, and topicInput instead of eltInput

Cool, I will update the patch ASAP.

Changed the variable names.

Attachment #9072528 - Attachment is obsolete: true
Attachment #9072528 - Flags: review?(clokep)
Attachment #9072793 - Flags: review+

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/402119bccd02
fixed editing of chat room topic. r=mkmelin DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Attachment #9072793 - Flags: approval-comm-beta+
Target Milestone: --- → Thunderbird 69.0
You need to log in before you can comment on or make changes to this bug.