Status

()

Core
Layout
P3
major
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: Moiz Dohadwala, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
There is a serious problem with the layout of text in this page. Testing with
the 1.0 release build 2002053012 on win2k, sp2
(Reporter)

Comment 1

16 years ago
Created attachment 87956 [details]
snapshot of web page showing overflow

Comment 2

16 years ago
WFM with Trunk-Build 2002061408 and Windows XP.

Comment 3

16 years ago
Confirming with Linux 1.0

Text in the left hand column is not properly wrapped.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago
May be poor page design, the text may be too wide for the table.

Updated

16 years ago
Priority: -- → P3
(Reporter)

Comment 5

16 years ago
yes, but mozilla must degrade gracefully. clipped text is better than text
overflowing out of the table.

Comment 6

16 years ago
No overflow under build 2002061808...text in left hand column is still
improperly wrapped however, but seems to be due to poor page design (and
mozilla's wrapping doesn't seem to be too ungraceful).

Comment 7

16 years ago
Just to clarify, with 1.0 Linux, I saw wrapping too, but not overflowing.

Updated

16 years ago
Target Milestone: --- → Future

Comment 8

15 years ago
Moiz:
With 2003010705 on Win2k it works for me:
On the right side of the page nothing overflows anymore.
The left hand column ("Server: Intel Xeon...") also looks fine because the text
is smaller now.
If you set the text size to 150% it again wraps as in the screenshot, but that
is totally correct behaviour: maybe you'd expect the text to stay inside the
orange area, but this area is only a background image and the page "designer"
used lots of spaces ( ) for making the text appear where he wanted it to
appear.
Obviously he did not test his design with Mozilla or different text sizes.

So please report if the left hand column or the table at the right was the
reason for filing this bug - and if you still see the problem at the right side
with a current Mozilla build.

If it was the right side only, this is gonna be a WFM, if you also filed it
because of the left column, it will go to Evang.

Comment 9

15 years ago
-> WFM

See comment #8: the originally reported problem is gone.
When the text on the left side wraps, it overwrites the blue background, but the
page is designed like that and if IE could make that text larger, it also would
happen there.
One problem is left: the links in the left box look different in IE5. That's
because they have the class "006699" (and others). I think HTML 4 supposes the
class names should not begin with a number, but it looks not clear on that for me.
However, if I rename the class to "x006699", Mozilla renders it like IE.
If you consider that an evangelism bug, please open one; that's not this bug.

Comment 10

15 years ago
Created attachment 115095 [details]
Shows use of classes with(out) leading number.

As described in the comment above:
The first line is like in the web page; the style rule is only used by IE.
In the second line the class name begins with a letter and Mozilla also uses
the style rule.

Comment 11

15 years ago
really WFM
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 12

15 years ago
wfm too, win2k sp3, 2003021408
You need to log in before you can comment on or make changes to this bug.