Closed Bug 1523506 Opened 2 years ago Closed 2 years ago

dom/base/TimeoutManager.cpp:149:13: error: unused variable 'now' [-Werror,-Wunused-variable]

Categories

(Core :: Performance, defect)

60 Branch
Unspecified
FreeBSD
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1523333
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- fix-optional
firefox67 --- fixed

People

(Reporter: jbeich, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 obsolete file)

GeckoProfiler isn't available on many Tier3 platforms: Linux powerpc/sparc/s390x, BSDs, Solaris.

$ c++ -v
FreeBSD clang version 7.0.1 (tags/RELEASE_701/final 349250) (based on LLVM 7.0.1)
Target: x86_64-unknown-freebsd13.0
Thread model: posix
InstalledDir: /usr/bin

$ echo "ac_add_options --enable-warnings-as-errors # mimic MOZ_AUTOMATION" >>.mozconfig
$ ./mach bootstrap
$ ./mach build
[...]
In file included from objdir/dom/base/Unified_cpp_dom_base5.cpp:110:
dom/base/TimeoutManager.cpp:149:13: error: unused variable 'now' [-Werror,-Wunused-variable]
TimeStamp now;
^
1 error generated.

Comment on attachment 9039714 [details]
Bug 1523506 - Move the declaration of the now variable to within the MOZ_GECKO_PROFILER block;

I confirm. It unbreaks --enable-warnings-as-errors on FreeBSD.

Attachment #9039714 - Flags: feedback+

Comment on attachment 9039714 [details]
Bug 1523506 - Move the declaration of the now variable to within the MOZ_GECKO_PROFILER block;

This would break functionality. I'm fixing this as part of bug 1523333

Attachment #9039714 - Flags: review-
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1523333
Attachment #9039714 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.