Forward and Back intermittently go to wrong pages / frames

VERIFIED DUPLICATE of bug 13329

Status

()

Core
RDF
P3
normal
VERIFIED DUPLICATE of bug 13329
19 years ago
19 years ago

People

(Reporter: cpratt, Assigned: Radha on family leave (not reading bugmail))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: , URL)

(Reporter)

Description

19 years ago
Build ID: 1999092909
Platform: all

To reproduce:
- Launch apprunner
- Load random pages, occasionally pressing Back and/or Forward
[- You can also try loading a page with frames, eg bild.de or buchkatalog.de and
doing the same there; that seems to expedite the process for me, but YMMV]

Result: Eventually, Back and/or Forward do the wrong thing. They may skip pages
going back, not do anything, or do the opposite (that is, go Back when you
clicked Forward). I don't have a sure-fire way to reproduce this but leger and
others have seen the problem.

Expected result: Back always go back to the previously viewed page; forward does
the opposite.

Updated

19 years ago
Assignee: waterson → radha

Comment 1

19 years ago
radha: this is probably your baby :-)
Status: NEW → ASSIGNED
Target Milestone: M11
Whiteboard:
Already checked in a fix to the M10 branch. Shall check in to the trunk once it
opens
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 13329 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED
Target Milestone: M11 → M10

Comment 4

19 years ago
Marking Verified as a dup.
You need to log in before you can comment on or make changes to this bug.