Closed Bug 1523614 Opened 4 years ago Closed 2 years ago

Right-click does not work in text-based netmonitor sidepanels

Categories

(DevTools :: Netmonitor, defect, P3)

67 Branch
Unspecified
All
defect

Tracking

(firefox65 unaffected, firefox66 wontfix, firefox67 wontfix, firefox81 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
firefox65 --- unaffected
firefox66 --- wontfix
firefox67 --- wontfix
firefox81 --- fixed

People

(Reporter: uskolor, Assigned: bomsy, Mentored)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

Attached image 1.jpg

User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

Hello I would like ask about right mouse button.I can't copy website links at Web developer tools.

Actual results:

I should copy links at Web developer tools but I can't right button doesn't works

Picture show this issue .

Expected results:

In stable Firefox I can copy but at beta doesn't

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0 (20190204092937)

I've tested this report on Windows 10 and Ubuntu 18.10 using the latest Nightly, Beta and Fx release builds. I was able to reproduce the mentioned behavior. On the Firefox release build, I am able to successfully copy from DevTools. On the Beta and Nightly, I`m not able to do so. The right mouse click does not trigger the context menu.

Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
OS: Unspecified → All
Product: Firefox → DevTools

I can confirm too, on macOS, with Firefox 66 and 67.
It does work with Firefox 65 though. So it seems like a regression.

Component: General → Netmonitor
Summary: Web developer tools right button not works 2019-01-29 → Right-click does not works in the netmonitor

Thanks for the report!

This looks like a regression from bug 1495797
@Lenka, can you confirm it?

Honza

Flags: needinfo?(lpelechova)
Priority: -- → P3

(In reply to Jan Honza Odvarko [:Honza] (always need-info? me) from comment #3)

Thanks for the report!

This looks like a regression from bug 1495797
@Lenka, can you confirm it?

Honza

I checked and it comes from this bug . Where <input> was replaced by <span> for the values.

I can try to have a look.
Lenka

Flags: needinfo?(lpelechova)

Hey,
I'm and outreachy applicant and would like to work on this project.
Can you please guide me about the issue?
Thanks

(In reply to paarmita1998 from comment #5)

Hey,
I'm and outreachy applicant and would like to work on this project.
Can you please guide me about the issue?

Thanks for the help!

  1. Assuming you have downloaded Firefox source already...

  2. The Headers panel is implemented in this file:
    https://searchfox.org/mozilla-central/source/devtools/client/netmonitor/src/components/HeadersPanel.js

  3. The URL is rendered here:
    https://searchfox.org/mozilla-central/rev/dc0adc07db3df9431a0876156f50c65d580010cb/devtools/client/netmonitor/src/components/HeadersPanel.js#380

  4. Here is an example of attaching a context menu to the "Header bar" (displayed at the top of the list of requests in the panel content)
    https://searchfox.org/mozilla-central/rev/dc0adc07db3df9431a0876156f50c65d580010cb/devtools/client/netmonitor/src/components/RequestListHeader.js#173

Search for onContextMenu in this file to see all interesting places.

  1. The menu for the Header is implemented here:
    https://searchfox.org/mozilla-central/source/devtools/client/netmonitor/src/widgets/RequestListHeaderContextMenu.js

  2. You should implement a new menu in widgets/HeadersPanelContextMenu.js (create the file) and attach it to the URL element summaryUrl (mentioned in step #2). Actually, you could pass new argument onContextMenu into the renderSummary method and attach it to all values rendered using renderSummary (i.e. Request URL, Request Method, address, etc.)

  3. The menu should have just one item: "Copy".

Assignee: nobody → paarmita1998
Mentor: odvarko
Status: NEW → ASSIGNED

Hey,
Does this bug happen in MacOS?

Okay, I got the issue. Working on it.

Hi :Paarmita,

How's it going with this bug? Let me know if you need help or anything. I'd like to work on this bug - it would help me get more familiar with the code base.

Thanks!

Hey,
I'm working on this bug and almost done with it, needs to fix some bugs.

Hi Paarmita. Do you still intend to work on this bug? If so, no problem at all if you need more time. But I prefer to ask in case you do not have time anymore, in which case we can make this bug unassigned again so other people can pick it up.

Flags: needinfo?(paarmita1998)

Unassigning this bug.

Assignee: paarmita1998 → nobody
Status: ASSIGNED → NEW
Flags: needinfo?(paarmita1998)
Summary: Right-click does not works in the netmonitor → Right-click does not work in the netmonitor

After 1 year my submission this copy still doesn't works.In Poland we said Mozilla has pipe as in my Car .of course we have time .for next year.

We are working on refactoring this panel and should also get to this as a follow up.

Same applies to the Timings panel.

Depends on: 1613884
Summary: Right-click does not work in the netmonitor → Right-click does not work in text-based netmonitor sidepanels

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression

As prior art, the Changes panel has a good copy menu that also allows copying the current selection. Text-based panels could hook into the same mechanism:

https://searchfox.org/mozilla-central/source/devtools/client/inspector/changes/ChangesContextMenu.js

Firefox 75 nothing change situation is the same .Doesn't works.

Blocks: 1617167

This should be fixed now by Bug 1631295.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

iiiiiikolor@gmail.com this should be on nightly.
Please confirm that it works for you.

Thanks

Flags: needinfo?(iiiiiikolor)

Hubert in 76.0.1 this doesn't works .I do not use Nightly.

Flags: needinfo?(iiiiiikolor)

Bomsy, bug 1631295 partially fixes it for the URL section, but the other fields for Status, Address, etc don't have a context menu.

Status: RESOLVED → REOPENED
Flags: needinfo?(hmanilla)
Resolution: FIXED → ---

Add a new context menu for the headers sidepanel with , Copy and Copy all

Assignee: nobody → hmanilla

I've opened a patch to fix

Flags: needinfo?(hmanilla)
Attachment #9150704 - Attachment description: Bug 1523614 Add context menu for headers summary section r=honza → Bug 1523614 Add copy/copy all context menu for headers summary and properties view r=honza
Pushed by hmanilla@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f46ad63286fa
Add copy/copy all context menu for headers summary and properties view r=nchevobbe
Status: REOPENED → RESOLVED
Closed: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
Duplicate of this bug: 1638935
You need to log in before you can comment on or make changes to this bug.