Closed Bug 1523702 Opened 10 months ago Closed 10 months ago

Crash in mozilla::ipc::ProcessLink::SendMessage | IPC_Message_Name=PContent::Msg_StoreAndBroadcastBlobURLRegistration

Categories

(Core :: DOM: Core & HTML, defect, critical)

Unspecified
Windows 10
defect
Not set
critical

Tracking

()

VERIFIED FIXED
mozilla67
Tracking Status
firefox-esr60 --- unaffected
firefox65 --- unaffected
firefox66 --- unaffected
firefox67 + verified

People

(Reporter: marcia, Assigned: baku)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(2 files)

This bug is for crash report bp-f0c434d4-7da5-4e5e-a885-be7a00190129.

Seen while looking at 67 crash stats: https://bit.ly/2FSMRWQ. Crashes started using 20190129103321. 6 crashes/3 installs so far

Possible regression range based on Build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=5d9c5aa981a5b824e6132c923c2f201b3fa49397&tochange=815f7149b30b27f79395d9a0155c1ebeb4fca8b5

Top 10 frames of crashing thread:

0 xul.dll mozilla::ipc::ProcessLink::SendMessage ipc/glue/MessageLink.cpp:152
1 xul.dll mozilla::ipc::MessageChannel::Send ipc/glue/MessageChannel.cpp:995
2 xul.dll mozilla::dom::PContentChild::SendStoreAndBroadcastBlobURLRegistration ipc/ipdl/PContentChild.cpp:4535
3 xul.dll static void mozilla::dom::BroadcastBlobURLRegistration dom/file/uri/BlobURLProtocolHandler.cpp:148
4 xul.dll mozilla::dom::BlobURLProtocolHandler::AddDataEntry dom/file/uri/BlobURLProtocolHandler.cpp:548
5 xul.dll static void mozilla::dom::URLMainThread::CreateObjectURL dom/url/URLMainThread.cpp:83
6 xul.dll static bool mozilla::dom::URL_Binding::createObjectURL dom/bindings/URLBinding.cpp:967
7 xul.dll js::InternalCallOrConstruct js/src/vm/Interpreter.cpp:533
8 xul.dll static bool InternalCall js/src/vm/Interpreter.cpp:588
9 xul.dll static bool Interpret js/src/vm/Interpreter.cpp:3068

Very low volume so far but maybe baku has an idea if something's changed?

Flags: needinfo?(amarchesini)

80 crashes in a week is significant for the Nightly channel. Tracking for 67.

Assignee: nobody → amarchesini
Flags: needinfo?(amarchesini)
Pushed by amarchesini@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/183ac72fd614
Max IPC message size for InputStream serialization, r=smaug
https://hg.mozilla.org/integration/autoland/rev/903d62a948d2
Max IPC message size for InputStream serialization - tests, r=smaug
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67

No reports since this fix shipped in Nightly.

Status: RESOLVED → VERIFIED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.