Closed Bug 1523710 Opened 1 year ago Closed 1 year ago

Convert Alerts section/controllers to React

Categories

(Tree Management :: Perfherder, enhancement, P1)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sclements, Assigned: sclements)

References

(Regressed 1 open bug)

Details

Attachments

(2 files)

This involves converting several different parts, including the 'PhBugs' factory, 'ModifyAlertSummaryCtrl', 'EditAlertSummaryNotesCtrl', 'MarkDownstreamAlertsCtrl', ''ReassignAlertsCtrl', 'AlertsCtrl' and corresponding templates (will need to file separate pull requests for where it makes sense).

Summary: Convert Alerts controller to React → Convert Alerts section/controllers to React
Depends on: 1518492
Blocks: 1518492
No longer depends on: 1518492
Assignee: sclements → nobody
Status: ASSIGNED → NEW
Assignee: nobody → sclements
Priority: P2 → P1
Blocks: 1541299
No longer blocks: 1520712, 1520714
No longer blocks: 1541299
Depends on: 1541299

Added the meta bug 1541299 for new features since I won't be working on those as part of the conversion.

Blocks: 1541299
No longer depends on: 1541299
No longer blocks: 1536018
Blocks: 1536018
Status: NEW → ASSIGNED

Ionut, can you test the new alerts view on prototype (per the pr above)?

Flags: needinfo?(igoldan)

This has been tested and merged: https://github.com/mozilla/treeherder/pull/5005

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Flags: needinfo?(igoldan)
Resolution: --- → FIXED
Regressions: 1558752
Regressions: 1559146
Regressions: 1559149
Regressions: 1584145
Regressions: 1595111
No longer blocks: 1536018
You need to log in before you can comment on or make changes to this bug.