HTML compose pref not observed unless a server is selected

VERIFIED FIXED in M12

Status

SeaMonkey
MailNews: Message Display
P2
critical
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
** Observed with 9/29/99 Win32 build **

The last build I know where this is not a problem is one from
9/17/99.

With the above build, the plain text mail window does not come
up and you are instead offered the default HTML compose window
unless you explicitly select some mail server icon.

I happen to have only 1 "id" profile for all my servers.

I usually start "apprunner -mail" and go straight to
"New Msg" button without selecting a server icon to
start composing mail. Unfortunately, "compose_html, false"
setting is ignored under this condition and the default, i.e.
HTML mail compose, is provided.

This was working OK with the 9/17/99 build -- and perhaps
other later builds.

This also seems to fail when you open a new mail window
dierctly from a browser window.

As far as I can tell, there is no explicit "default id" setting in
the prefs.js file currently. Yet, there must be a heuristic to
determine which one of the "multiple id" settings is the default
in case no server is selected.

Please fix this for M11 if at all possible -- this is clearly a
regression.
(Reporter)

Updated

18 years ago
Priority: P3 → P1
(Reporter)

Comment 1

18 years ago
There is an easy workaround, of course. However, not everyone
wants HTML mail and if you want more people to use Mail with M11, being
able to open a plain text mail compose window without any complication
is quite important in my opinion.
(Reporter)

Comment 2

18 years ago
I guess M11 is now M10. So my request is really for M10.

Comment 3

18 years ago
Reassign to ducarroz for M11, cc alecf.

Kat, the convention is that the reporter sets the severity, and the bug owner
sets the priority.

Updated

18 years ago
Assignee: ducarroz → sspitzer

Comment 4

18 years ago
Alec sez Seth wrote this, so reassigning to him

Comment 5

18 years ago
*** Bug 15283 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

18 years ago
To be more explicit about the workaround, all you need to do
to get the plain text window is to select/higlight a server icon. You
don't have to open the mailbox files or read mail or log in
to the server.

Comment 7

18 years ago
I tend to use apprunner -compose for testing and for sending quick messages, and
unfortunately there's no workaround for that case.
accepting.  marking all milestone 11.

Updated

18 years ago
QA Contact: lchiang → laurel

Comment 9

18 years ago
*** Bug 17000 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
*** Bug 17310 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Target Milestone: M11 → M15
(Reporter)

Comment 11

18 years ago
I should say that the current default (when no server is selected) is "Plain Text" rather than
"HTML". The original bug "HTML Compose pref is not observed unless a server is selcted" is still correct but
this is a note to confirm that the default in such a case changed.

Perhaps one way to deal with this without creating a special UI is to have one "default" server
among several servers (as we do in IMAP in 4.x) and then assume the HTML Compose setting on that
server as the default.
(Assignee)

Updated

18 years ago
Assignee: sspitzer → ducarroz
Status: ASSIGNED → NEW
Target Milestone: M15 → M12
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

18 years ago
Fixed and checked in.

The default identity is used when opening a msg compose window from somewhere else than the 3 pane window or
without account selected. Today, as the notion of default identity is not yet implemented, the first identity is
choosed.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 13

18 years ago
Using win32 build 1999111909m12 and build 1999112108m12 build on linux and mac
the default compose window (clicking New Msg with no account selected) is
whatever the 1st account is set to.  Verified
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.