Perma Windows Assertion failure: false, at z:/build/build/src/gfx/vr/service/VRService.cpp:180 when Gecko 67 merges to beta on 2019-03-11

VERIFIED FIXED in Firefox 66

Status

()

defect
P2
normal
VERIFIED FIXED
5 months ago
5 months ago

People

(Reporter: intermittent-bug-filer, Assigned: daoshengmu)

Tracking

unspecified
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 fixed, firefox67+ verified)

Details

Attachments

(1 attachment)

Reporter

Description

5 months ago
treeherder

#[markdown(off)]
Filed by: rgurzau [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=224948018&repo=try

https://queue.taskcluster.net/v1/task/BAjH6SWJSxW9utneFvM3Kg/runs/0/artifacts/public/logs/live_backing.log

https://hg.mozilla.org/mozilla-central/raw-file/tip/layout/tools/reftest/reftest-analyzer.xhtml#logurl=https://queue.taskcluster.net/v1/task/BAjH6SWJSxW9utneFvM3Kg/runs/0/artifacts/public/logs/live_backing.log&only_show_unexpected=1

13:24:30 INFO - REFTEST TEST-START | file:///Z:/task_1548852540/build/tests/reftest/tests/dom/vr/test/reftest/draw_rect.html == file:///Z:/task_1548852540/build/tests/reftest/tests/dom/vr/test/reftest/wrapper.html?draw_rect.png
13:24:30 INFO - nsStringStats
13:24:30 INFO - => mAllocCount: 6868
13:24:30 INFO - => mReallocCount: 0
13:24:30 INFO - => mFreeCount: 6868
13:24:30 INFO - => mShareCount: 4614
13:24:30 INFO - => mAdoptCount: 384
13:24:30 INFO - => mAdoptFreeCount: 384
13:24:30 INFO - => Process ID: 9116, Thread ID: 5512
13:24:30 INFO - REFTEST INFO | SET PREFERENCE pref(dom.vr.puppet.enabled,true)
13:24:30 INFO - REFTEST INFO | SET PREFERENCE pref(dom.vr.test.enabled,true)
13:24:30 INFO - REFTEST INFO | SET PREFERENCE pref(dom.vr.require-gesture,false)
13:24:30 INFO - REFTEST INFO | SET PREFERENCE pref(dom.vr.puppet.submitframe,1)
13:24:30 INFO - REFTEST INFO | SET PREFERENCE pref(dom.vr.display.rafMaxDuration,200)
13:24:30 INFO - REFTEST INFO | SET PREFERENCE pref(dom.vr.display.enumerate.interval,0)
13:24:30 INFO - REFTEST INFO | SET PREFERENCE pref(dom.vr.controller.enumerate.interval,0)
13:24:30 INFO - REFTEST TEST-LOAD | file:///Z:/task_1548852540/build/tests/reftest/tests/dom/vr/test/reftest/draw_rect.html | 0 / 2 (0%)
13:24:30 INFO - ++DOMWINDOW == 6 (00000291E204E400) [pid = 2736] [serial = 6] [outer = 00000291E1E5A000]
13:24:30 INFO - [Child 2736, Main Thread] WARNING: NS_ENSURE_TRUE(nsContentUtils::IsJavascriptMIMEType(type)) failed: file z:/build/build/src/dom/script/ScriptLoader.cpp, line 1451
13:24:30 INFO - [Child 2736, Main Thread] WARNING: NS_ENSURE_TRUE(nsContentUtils::IsJavascriptMIMEType(type)) failed: file z:/build/build/src/dom/script/ScriptLoader.cpp, line 1451
13:24:30 INFO - WARN: initializeD3DDevice(770): Failed creating Debug D3D11 device - falling back to release runtime.
13:24:30 INFO - Initializing context 00000291E2B76000 surface 00000291E2B28280 on display 00000291DBEEBCD0
13:24:30 INFO - ### XPCOM_MEM_BLOAT_LOG defined -- logging bloat/leaks to c:\users\task_1548852540\appdata\local\temp\tmps4cyen.mozrunner\runreftest_leaks_tab_pid3084.log
13:24:30 INFO - [Child 3084, Main Thread] WARNING: No CID found when attempting to map contract ID: file z:/build/build/src/xpcom/components/nsComponentManager.cpp, line 739
13:24:30 INFO - [Child 2736, Main Thread] WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file z:/build/build/src/dom/base/nsContentUtils.cpp, line 3766
13:24:30 INFO - REFTEST INFO | drawWindow flags = DRAWWINDOW_DRAW_CARET | DRAWWINDOW_DRAW_VIEW | DRAWWINDOW_USE_WIDGET_LAYERS; window size = 816,1039; test browser size = 800,1000
13:24:30 INFO - [GPU 9184, VRService] WARNING: VR: file z:/build/build/src/gfx/vr/service/VRService.cpp, line 179
13:24:30 INFO - Assertion failure: false, at z:/build/build/src/gfx/vr/service/VRService.cpp:180
13:24:30 INFO - #01: nsresult mozilla::detail::RunnableMethodImpl<mozilla::gfx::VRService *,void (mozilla::gfx::VRService::*)(),1,mozilla::RunnableKind::Standard>::Run() [xpcom/threads/nsThreadUtils.h:1174]
13:24:30 INFO -
13:24:30 INFO - #02: MessageLoop::RunTask(already_AddRefed<nsIRunnable>) [ipc/chromium/src/base/message_loop.cc:443]
13:24:30 INFO -
13:24:30 INFO - #03: MessageLoop::DeferOrRunPendingTask(MessageLoop::PendingTask &&) [ipc/chromium/src/base/message_loop.cc:450]
13:24:30 INFO -
13:24:30 INFO - #04: MessageLoop::DoWork() [ipc/chromium/src/base/message_loop.cc:523]
13:24:30 INFO -
13:24:30 INFO - #05: base::MessagePumpDefault::Run(base::MessagePump::Delegate *) [ipc/chromium/src/base/message_pump_default.cc:35]
13:24:30 INFO -
13:24:30 INFO - #06: MessageLoop::RunHandler() [ipc/chromium/src/base/message_loop.cc:309]
13:24:30 INFO -
13:24:30 INFO - #07: base::Thread::ThreadMain() [ipc/chromium/src/base/thread.cc:192]
13:24:30 INFO -
13:24:30 INFO - #08: static unsigned long `anonymous namespace'::ThreadFunc(void *) [ipc/chromium/src/base/platform_thread_win.cc:31]
13:24:30 INFO -
13:24:30 INFO - #09: KERNEL32.DLL + 0x12774
13:24:30 INFO -
13:24:30 INFO - #10: static void patched_BaseThreadInitThunk(int, void *, void *) [mozglue/build/WindowsDllBlocklist.cpp:735]
13:24:30 INFO -
13:24:30 INFO - #11: ntdll.dll + 0x70d51
13:24:30 INFO -
13:24:30 INFO - [GFX1-]: Receive IPC close with reaso[GFX1-]: Receive In[PC =AbnGclose with reason=AbnorFomX1alShutr-dmaown
13:24:30 INFO - lShutdow]:n Receive IPC close with reason=Abnor
13:24:30 INFO - malShutdown

[Tracking Requested - why for this release]:

Summary: Intermittent Assertion failure: false, at z:/build/build/src/gfx/vr/service/VRService.cpp:180 → Perma Assertion failure: false, at z:/build/build/src/gfx/vr/service/VRService.cpp:180 when Gecko 67 merges to beta on 2019-03-11
Blocks: 1514417
Summary: Perma Assertion failure: false, at z:/build/build/src/gfx/vr/service/VRService.cpp:180 when Gecko 67 merges to beta on 2019-03-11 → Perma Windows Assertion failure: false, at z:/build/build/src/gfx/vr/service/VRService.cpp:180 when Gecko 67 merges to beta on 2019-03-11

The assertion is in code added in bug 1514417. Please have a look.

Flags: needinfo?(dmu)

Changing the priority to p2 as the bug is tracked by a release manager for the current nightly.
See How Do You Triage for more information

Priority: P5 → P2
Assignee

Updated

5 months ago
See Also: → 1523925
Assignee

Comment 4

5 months ago

MozReview-Commit-ID: 5P7D75wAWI7

Assignee

Updated

5 months ago
Assignee: nobody → dmu
Flags: needinfo?(dmu)

Comment 5

5 months ago
Pushed by dmu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/52f541c1147e
Fix open VR shmem mutex failed issue when without VR process. r=kip

Comment 6

5 months ago
Backout by rgurzau@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ac3ba5d1c7a5
Backed out changeset 52f541c1147e for xpcshell test crash mozilla::gfx::VR on a CLOSED TREE.

Backed out changeset 52f541c1147e (bug 1523926) for xpcshell test crash mozilla::gfx::VR on a CLOSED TREE.

Backout link: https://hg.mozilla.org/integration/autoland/rev/ac3ba5d1c7a53bbd205e421db2e422492aa422fb

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=testfailed%2Cbusted%2Cexception&selectedJob=225542684&revision=52f541c1147efcba8febe1c26a51181bb0901233

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=225542684&repo=autoland&lineNumber=1145

Log snippet:

22:10:03 INFO - TEST-START | browser/components/syncedtabs/test/xpcshell/test_SyncedTabsDeckStore.js
22:10:04 INFO - mozcrash Saved minidump as Z:\task_1549057574\build\blobber_upload_dir\5292a3ca-42d4-4f6d-9b33-c5aa60ff2c04.dmp
22:10:04 INFO - mozcrash Saved app info as Z:\task_1549057574\build\blobber_upload_dir\5292a3ca-42d4-4f6d-9b33-c5aa60ff2c04.extra
22:10:04 WARNING - PROCESS-CRASH | xpcshell-remote.ini:browser/components/extensions/test/xpcshell/test_ext_browsingData_cookies_cache.js | application crashed [@ mozilla::gfx::VRSystemManagerExternal::VRSystemManagerExternal(mozilla::gfx::VRExternalShmem *)]
22:10:04 INFO - Crash dump filename: c:\users\task_1549057574\appdata\local\temp\xpc-other-r900dt\5292a3ca-42d4-4f6d-9b33-c5aa60ff2c04.dmp
22:10:04 INFO - Operating system: Windows NT
22:10:04 INFO - 10.0.15063
22:10:04 INFO - CPU: amd64
22:10:04 INFO - family 6 model 85 stepping 3
22:10:04 INFO - 8 CPUs
22:10:04 INFO - GPU: UNKNOWN
22:10:04 INFO - Crash reason: EXCEPTION_BREAKPOINT
22:10:04 INFO - Crash address: 0x7ff84dce2ab9
22:10:04 INFO - Assertion: Unknown assertion type 0x00000000
22:10:04 INFO - Process uptime: 2 seconds
22:10:04 INFO - Thread 0 (crashed)
22:10:04 INFO - 0 xul.dll!mozilla::gfx::VRSystemManagerExternal::VRSystemManagerExternal(mozilla::gfx::VRExternalShmem *) [gfxVRExternal.cpp:52f541c1147efcba8febe1c26a51181bb0901233 : 460 + 0x0]
22:10:04 INFO - rax = 0x00007ff853edc63d rdx = 0x000000fc151fe858
22:10:04 INFO - rcx = 0x00007ff8731bfac8 rbx = 0x000002434d8105e0
22:10:04 INFO - rsi = 0x000002434d8105e0 rdi = 0x0000000000000000
22:10:04 INFO - rbp = 0x0000000000000830 rsp = 0x000000fc151fe840
22:10:04 INFO - r8 = 0x000000fc151fe850 r9 = 0x000000fc151fe848
22:10:04 INFO - r10 = 0x0000000000000000 r11 = 0x000000fc151f9e80
22:10:04 INFO - r12 = 0x000000fc151fee18 r13 = 0x000000fc151fee28
22:10:04 INFO - r14 = 0x000002434d856190 r15 = 0x000002434d879060
22:10:04 INFO - rip = 0x00007ff84dce2ab9
22:10:04 INFO - Found by: given as instruction pointer in context
22:10:04 INFO - 1 xul.dll!mozilla::gfx::VRSystemManagerExternal::Create(mozilla::gfx::VRExternalShmem *) [gfxVRExternal.cpp:52f541c1147efcba8febe1c26a51181bb0901233 : 622 + 0xb]
22:10:04 INFO - rbx = 0x000002434d8105e0 rbp = 0x0000000000000830
22:10:04 INFO - rsp = 0x000000fc151fe8e0 r12 = 0x000000fc151fee18
22:10:04 INFO - r13 = 0x000000fc151fee28 r14 = 0x000002434d856190
22:10:04 INFO - r15 = 0x000002434d879060 rip = 0x00007ff84dce2ef8
22:10:04 INFO - Found by: call frame info
22:10:04 INFO - 2 xul.dll!mozilla::gfx::VRManager::VRManager() [VRManager.cpp:52f541c1147efcba8febe1c26a51181bb0901233 : 94 + 0xc]
22:10:04 INFO - rbx = 0x000002434d8105e0 rbp = 0x0000000000000830
22:10:04 INFO - rsp = 0x000000fc151fe930 r12 = 0x000000fc151fee18
22:10:04 INFO - r13 = 0x000000fc151fee28 r14 = 0x000002434d856190
22:10:04 INFO - r15 = 0x000002434d879060 rip = 0x00007ff84dceaba7
22:10:04 INFO - Found by: call frame info
22:10:04 INFO - 3 xul.dll!mozilla::gfx::VRManager::ManagerInit() [VRManager.cpp:52f541c1147efcba8febe1c26a51181bb0901233 : 60 + 0x8]
22:10:04 INFO - rbx = 0x000002434d8105e0 rbp = 0x0000000000000830
22:10:04 INFO - rsp = 0x000000fc151fe990 r12 = 0x000000fc151fee18
22:10:04 INFO - r13 = 0x000000fc151fee28 r14 = 0x000002434d856190
22:10:04 INFO - r15 = 0x000002434d879060 rip = 0x00007ff84dcea818
22:10:04 INFO - Found by: call frame info
22:10:04 INFO - 4 xul.dll!mozilla::gfx::GPUParent::RecvInit(nsTArray<mozilla::gfx::GfxPrefSetting> &&,nsTArray<mozilla::gfx::GfxVarUpdate> &&,mozilla::gfx::DevicePrefs const &,nsTArray<mozilla::gfx::LayerTreeIdMapping> &&) [GPUParent.cpp:52f541c1147efcba8febe1c26a51181bb0901233 : 255 + 0x5]
22:10:04 INFO - rbx = 0x000002434d8105e0 rbp = 0x0000000000000830
22:10:04 INFO - rsp = 0x000000fc151fe9c0 r12 = 0x000000fc151fee18
22:10:04 INFO - r13 = 0x000000fc151fee28 r14 = 0x000002434d856190
22:10:04 INFO - r15 = 0x000002434d879060 rip = 0x00007ff84dccdea1
22:10:04 INFO - Found by: call frame info
22:10:04 INFO - 5 xul.dll!mozilla::gfx::PGPUParent::OnMessageReceived(IPC::Message const &) [PGPUParent.cpp: : 678 + 0x26]
22:10:04 INFO - rbx = 0x000002434d8105e0 rbp = 0x0000000000000830
22:10:04 INFO - rsp = 0x000000fc151fedb0 r12 = 0x000000fc151fee18
22:10:04 INFO - r13 = 0x000000fc151fee28 r14 = 0x000002434d856190
22:10:04 INFO - r15 = 0x000002434d879060 rip = 0x00007ff84d066fa9
22:10:04 INFO - Found by: call frame info
22:10:04 INFO - 6 xul.dll!mozilla::ipc::MessageChannel::DispatchAsyncMessage(IPC::Message const &) [MessageChannel.cpp:52f541c1147efcba8febe1c26a51181bb0901233 : 2160 + 0xd]
22:10:04 INFO - rbx = 0x000002434d8105e0 rbp = 0x0000000000000830
22:10:04 INFO - rsp = 0x000000fc151feef0 r12 = 0x000000fc151fee18
22:10:04 INFO - r13 = 0x000000fc151fee28 r14 = 0x000002434d856190
22:10:04 INFO - r15 = 0x000002434d879060 rip = 0x00007ff84ce576d0
22:10:04 INFO - Found by: call frame info
22:10:04 INFO - 7 xul.dll!mozilla::ipc::MessageChannel::DispatchMessage(IPC::Message &&) [MessageChannel.cpp:52f541c1147efcba8febe1c26a51181bb0901233 : 2087 + 0xb]
22:10:04 INFO - rbx = 0x000002434d8105e0 rbp = 0x0000000000000830
22:10:04 INFO - rsp = 0x000000fc151fef70 r12 = 0x000000fc151fee18
22:10:04 INFO - r13 = 0x000000fc151fee28 r14 = 0x000002434d856190
22:10:04 INFO - r15 = 0x000002434d879060 rip = 0x00007ff84ce557b6
22:10:04 INFO - Found by: call frame info
22:10:04 INFO - 8 xul.dll!mozilla::ipc::MessageChannel::RunMessage(mozilla::ipc::MessageChannel::MessageTask &) [MessageChannel.cpp:52f541c1147efcba8febe1c26a51181bb0901233 : 1936 + 0xb]
22:10:04 INFO - rbx = 0x000002434d8105e0 rbp = 0x0000000000000830
22:10:04 INFO - rsp = 0x000000fc151ff040 r12 = 0x000000fc151fee18
22:10:04 INFO - r13 = 0x000000fc151fee28 r14 = 0x000002434d856190
22:10:04 INFO - r15 = 0x000002434d879060 rip = 0x00007ff84ce566f9
22:10:04 INFO - Found by: call frame info
22:10:04 INFO - 9 xul.dll!mozilla::ipc::MessageChannel::MessageTask::Run() [MessageChannel.cpp:52f541c1147efcba8febe1c26a51181bb0901233 : 1967 + 0xc]
22:10:04 INFO - rbx = 0x000002434d8105e0 rbp = 0x0000000000000830
22:10:04 INFO - rsp = 0x000000fc151ff0c0 r12 = 0x000000fc151fee18
22:10:04 INFO - r13 = 0x000000fc151fee28 r14 = 0x000002434d856190
22:10:04 INFO - r15 = 0x000002434d879060 rip = 0x00007ff84ce56b49
22:10:04 INFO - Found by: call frame info
22:10:04 INFO - 10 xul.dll!nsThread::ProcessNextEvent(bool,bool *) [nsThread.cpp:52f541c1147efcba8febe1c26a51181bb0901233 : 1162 + 0x6]
22:10:04 INFO - rbx = 0x000002434d8105e0 rbp = 0x0000000000000830
22:10:04 INFO - rsp = 0x000000fc151ff100 r12 = 0x000000fc151fee18
22:10:04 INFO - r13 = 0x000000fc151fee28 r14 = 0x000002434d856190
22:10:04 INFO - r15 = 0x000002434d879060 rip = 0x00007ff84c72cd49
22:10:04 INFO - Found by: call frame info

Flags: needinfo?(dmu)

Comment 8

5 months ago
Pushed by dmu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/12b2328eedd1
Fix open VR shmem mutex failed issue when without VR process. r=kip
Assignee

Updated

5 months ago
Flags: needinfo?(dmu)

Comment 10

5 months ago
bugherder
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Blocks: 1524743
Assignee

Comment 12

5 months ago

:CosminS
please help backout my patch again, I am going to give an another fix for that.
Thanks

Flags: needinfo?(dmu) → needinfo?(csabou)
Comment hidden (Intermittent Failures Robot)
Assignee

Updated

5 months ago
See Also: → 1524929

Comment 14

5 months ago
Status: RESOLVED → REOPENED
Flags: needinfo?(csabou) → needinfo?(dmu)
Resolution: FIXED → ---
Target Milestone: mozilla67 → ---

Comment 15

5 months ago
Pushed by dmu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/be1beccfb86d
Fix open VR shmem mutex failed issue when without VR process. r=kip

Comment 16

5 months ago
bugherder
Status: REOPENED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
Assignee

Comment 17

5 months ago

Please let me know if it is also fixed in beta-sims. Thanks.

Flags: needinfo?(dmu) → needinfo?(btara)

Due to shift rotations, Bogdan won't be involved with beta simulations until Saturday. Sheriffs will update this bug tomorrow about the result of the beta simulation.

Flags: needinfo?(btara)
Assignee

Updated

5 months ago
Duplicate of this bug: 1524743

Setting this to affected because of the uplift in bug 1514417.

Can you request uplift here as well?

Flags: needinfo?(dmu)
Assignee

Comment 23

5 months ago

Comment on attachment 9040605 [details]
Bug 1523926 - Fix open VR shmem mutex failed issue when without VR process.

Beta/Release Uplift Approval Request

Feature/Bug causing the regression

bug 1514417

User impact if declined

This patch is paired with the patch comes from 1514417. We need to uplift it as well to fix some try tests failed. Although for the real users, it should have no influence.

Is this code covered by automated tests?

Yes

Has the fix been verified in Nightly?

Yes

Needs manual test from QE?

No

If yes, steps to reproduce

List of other uplifts needed

Bug 1514417

Risk to taking this patch

Low

Why is the change risky/not risky? (and alternatives if risky)

This patch is in order to resolve the new try tests failed that come by Bug 1514417.

String changes made/needed

Flags: needinfo?(dmu)
Attachment #9040605 - Flags: approval-mozilla-beta?

Comment on attachment 9040605 [details]
Bug 1523926 - Fix open VR shmem mutex failed issue when without VR process.

[Triage Comment]
Needed for bug 1514417, approved for 66.0b6.

Attachment #9040605 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.