Closed Bug 1524031 Opened 8 months ago Closed 7 months ago

Intermittent scrolling/frame-scrolling-attr-1.html == scrolling/frame-scrolling-attr-ref.html | image comparison, max difference: 1, number of differing pixels: {1,2}

Categories

(Core :: Layout, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla67
Tracking Status
firefox67 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: smaug)

References

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][stockwell disable-recommended])

Attachments

(1 file)

The differing pixel is at the top left corner of the second scrollbar from the top. Its color channel values are 1 lower than the reference case. (testcase has 235 in the red channel; reference case has 236)

The testcase and reference case agree on each of the other scrollbars, though they use (and agree on) the lower r=235 value for the top scrollbar and the higher r=236 value for the further-down scrollbars.

So, this is a bit odd, but probably best to just annotate as fuzzy if it happens frequently.

Markus left a very useful comment in bug 1157716 comment 4;

With APZ we always layerize the first scrollable element of the page, if the page itself is not scrollable. These additional layers can cause fuzzy reftest failures in two ways: By differences in blending, or by disabling sub-pixel text anti-aliasing. The latter is only a problem with unaccelerated drawing, because we don't support component alpha layers with BasicLayers. (We also don't support them with BasicCompositor, but "Reftest unaccelerated" tests BasicLayers and not BasicCompositor.

But, I am not sure this comment could be applied to this failure. :)

Duplicate of this bug: 1524668
Summary: Intermittent scrolling/frame-scrolling-attr-1.html == scrolling/frame-scrolling-attr-ref.html | image comparison, max difference: 1, number of differing pixels: 1 → Intermittent scrolling/frame-scrolling-attr-1.html == scrolling/frame-scrolling-attr-ref.html | image comparison, max difference: 1, number of differing pixels: {1,2}
Whiteboard: [retriggered]
See Also: → 1524774

ok, I'll mark the test with some fuzz. Apparently it is sensitive to any refresh driver scheduling changes.

So, perhaps this. I can't reproduce this locally, so need to just guess the numbers.

(layout/reftests/scrolling does fail locally in other tests)

Assignee: nobody → bugs
Flags: needinfo?(bugs)
Attachment #9041159 - Flags: review?(emilio)
Comment on attachment 9041159 [details] [diff] [review]
fuzzy-frame-scrolling-attr-1.html.diff

Review of attachment 9041159 [details] [diff] [review]:
-----------------------------------------------------------------

::: layout/reftests/scrolling/reftest.list
@@ -35,5 @@
>  == huge-horizontal-overflow.html huge-horizontal-overflow-ref.html
>  == huge-vertical-overflow.html huge-vertical-overflow-ref.html
>  fuzzy-if(asyncPan&&!layersGPUAccelerated,0-102,0-6818) == iframe-scrolling-attr-1.html iframe-scrolling-attr-ref.html
>  fuzzy-if(asyncPan&&!layersGPUAccelerated,0-140,0-6818) == iframe-scrolling-attr-2.html iframe-scrolling-attr-ref.html
> -== frame-scrolling-attr-1.html frame-scrolling-attr-ref.html

Can we do fuzzy-if(gtkWidget,0-1,0-2)? Or does it fail in other platforms too?
Attachment #9041159 - Flags: review?(emilio) → review+

I think I've seen it elsewhere too.

Pushed by opettay@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1fcffb8130e8
frame-scrolling-attr-1.html fails randomly - allow some fuzzyness, r=emilio
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla67
You need to log in before you can comment on or make changes to this bug.