Devtools Inspector doesn't show any nodes (besides `<html>`) for LinkedIn pages

RESOLVED FIXED in Firefox 67

Status

defect
P1
normal
RESOLVED FIXED
5 months ago
3 months ago

People

(Reporter: dholbert, Assigned: miker)

Tracking

({regression})

unspecified
Firefox 67
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox65 unaffected, firefox66 unaffected, firefox67 fixed)

Details

(Whiteboard: [qa-67b-p2])

Attachments

(1 attachment)

Reporter

Description

5 months ago

STR:

  1. Visit https://www.linkedin.com/m/login/
  2. Hit F12 and click the Inspector tab

EXPECTED RESULTS:
View of the page's full DOM

ACTUAL RESULTS:
Only the html node is shown, and we show it as if it were empty.

I think we're tripping over ourselves when trying to query for the DOM structure inside of it, because I see 4 errors in my Browser Console when I perform the STR. Those errors are:

Error writing response to: children     protocol.js:1201:13

Error while calling actor 'domwalker's method 'children' Permission denied to access property "jQuery224090793777484980741"    protocol.js:1042:5


get@https://static.licdn.com/sc/h/br/9tfzf1lqp8bajtgaz27f4wo8v:162:47
access@https://static.licdn.com/sc/h/br/9tfzf1lqp8bajtgaz27f4wo8v:163:66
_data@https://static.licdn.com/sc/h/br/9tfzf1lqp8bajtgaz27f4wo8v:171:189
protocol.js:1045:7


Protocol error (unknownError): Permission denied to access property "jQuery224090793777484980741" markup.js:196:7

The referenced JS files are
resource://devtools/shared/protocol.js
resource://devtools/client/inspector/markup/markup.js

Reporter

Comment 1

5 months ago

I think this is a pretty recent regression. e.g. nightly 2019-01-01 gives expected results.

Tracking down a regression range...

Keywords: regression
Reporter

Comment 3

5 months ago

Requesting tracking to be sure this doesn't fall off the radar
[Tracking Requested - why for this release]: regression, with devtools becoming unusable for some pages.

Thanks Daniel. We've also noticed this bug yesterday and Mike has been working on a fix in bug 1524005. So, closing this one for now.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1524005

I am tracking bug 1524005.

Reporter

Comment 6

5 months ago

Un-duping, since it seems bug 1524005 didn't fix this.

I can still reproduce this LinkedIn issue in Nightly 67.0a1 (2019-02-01) (64-bit) -- inspector still shows an empty <html> node, and I still see the same errors in Browser Console.

Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

You're right, it isn't fixed. Thanks for re-opening.
It probably is related to the same bug, but maybe another part of the code needs to be fixed just like bug 1524005.
Mike, any idea what could be going wrong here?

Priority: -- → P1

There are a bunch of these issues I have fixed lately... I will fix this then take a more general look through they inspector list to make sure we have them all.

So far they have all been bugs that have always been present but a particular page has e.g. a particular attribute name on a node that triggers the error.

Assignee: nobody → mratcliffe
Status: REOPENED → ASSIGNED
Flags: needinfo?(mratcliffe)
OS: Unspecified → All
Hardware: Unspecified → All
Has STR: --- → yes

I would have thought that the anonymous node fix would also have fixed this but we have had to manually add the before and after pseudo elements.

Comment 10

5 months ago
Pushed by mratcliffe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/94d34e0a4cbc
Devtools Inspector doesn't show any nodes (besides `<html>`) for LinkedIn pages r=rcaliman

Comment 11

5 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 67
Whiteboard: [qa-67b-p2]
You need to log in before you can comment on or make changes to this bug.